0

On my (SharePoint 2013) sub site I have a list (where users from a specific store can report errors). This list I want to share with another group of users, those who will do something about the errors (entrepreneurs). I want them to be able to Edit in this list: they don't need delete and create items, just being able to change an item is fine.

The problem is, I don't want them to have access to the sub site itself, because there is information on the sub site that they don't need to know about, they should only see this list. So they don't have any access at all to the sub site, but I'm giving them permission to the list.

However, it seems like since they can't access the sub site, no matter what permission I give them to the list (Edit, Contribute, Full Control), in the end they only have Reading-access to the list and can't even update an item.

This error message turns up whenever they try to edit something in the list:

Unable to communicate with the server

The entrepreneur group is external users, but that shouldn't matter, should it? I've added them to SharePoint groups with the right permissions.

Is there any possible way to solve this problem?

2

I've solved it now.

The solution was to first give the user group access to the sub site itself. Before I had given the user group the Permisson Level Read - but then they would be able to see all the links in QuickLaunch and go to the site.

However, I found there was already an existing Permission Level with very restricted permissions Restricted Interfaces for Translation that I could use. (Can open lists and folders and use remote interfaces). So on the site, I gave the user access to the site with this Permission Level.

After that, I went to the List Permission Settings and chose Contribute for the user group. Now they were able to edit the items in the list.

The Restricted Interfaces for Translation Permission Level did it: the users can edit in the list, but they can't see the site itself, no links are even showing. I'm content with this.

0

Similar issue in our environment and fix seemed to been adding "View Application Pages" and/or "Use Client Integration Features" permissions to the users.

Full permisisons assigned

List:

  • Edit Items
  • View Items
  • View Application Pages

Site:

  • View Pages
  • Use Remote Interfaces
  • Use Client Integration Features
  • Open

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.