I noticed the following error on that page where you define connection for User Profile Service Synchronization.

An error has occurred while accessing the SQL Server database or the SharePoint Server Search service. If this is the first time you have seen this message, try again later. If this problem persists, contact your administrator.

It was working fine before and now all of a sudden this error. Because of it, UPS is not syncing with AD. I did iisreset /noforce on APP server where CA is hosted but it didn't solve the problem. What to do?

  • Pardon if this seems like an obvious question, but have you tried connecting to the SQL server hosting your SP DB's with the account UPS is running with? This will let us double check that the account has the right permissions, is not locked out, has not had its password changed by SP, and that the password has not expired.
    – user24313
    Mar 24, 2014 at 19:13
  • Yes this is a good idea. I will check it out. Mar 25, 2014 at 8:37
  • I logged in to SQL Server using the account which I am using to create AD connection and it worked. Found one strange thing though, I have also got another SP Dev Farm on which UPS is working, I checked that the account which is used for AD connection, is not present in Database unlike production farm. But still the UPS is working there and not on production. Mar 25, 2014 at 10:41

6 Answers 6


Frank, I would start by reviewing the ULS logs. Generally there will be some events that point you in the direction of the issue (if not the actual issue itself.) The error says "...or the Service". If you can pull a correlation ID it may guide you to the group of transactions that are failing. There are MANY reasons that it would fail that do not require rebuilding the service.

If you find ULS entries and need help post them back here.

  • 1
    ok... so what was the resolution? Checking the logs was the next step, what was found in the logs?
    – shufler
    Dec 16, 2015 at 18:50

For me, the Forefront Identity Manager Service was not running. I started the service using the Services MMC and the error went away.

  • same was true in my case. The FIM Sync service showed started in windows and in SP on the app server, but the FIM service was stopped in windows services, services.msc and was running in services on server. Starting the windows forefront identity manager service fixed it and allowed the UPS to finish its sync operation.
    – Stacy
    Sep 12, 2018 at 17:00

I feel your pain. All I can think of is to re-create the User Profile (if nothing has changed in terms of service accounts). If you want to troubleshoot the issue, I would start with this great article: http://www.harbar.net/articles/sp2010ups.aspx

  • If I recreate UPS, will it have any problems? Like problem with MySite or People Search etc.? Mar 25, 2014 at 8:38

You can follow given below steps to solve the issue.

  1. Login to Central Administrations.

  2. Click Application Management link.

  3. In Service Applications click Manage services on server link.

  4. Start User Profile Synchronization Service. If its already start, stop it and start again.


I have gone through same scenario..It was working fine before and now all of a sudden this error. For me, the Forefront Identity Manager Service was not running. I started the service using the Services MMC and the error went away.



stop UPS sync service, and start it again, in my situation, it works

what I knew: 1 you AD should run well, it means: your AD, DNS, DHCP... should run normally 2 you SQL Server should run well, the service, the connection run well 3 if above is correct, focus in SharePoint configuration, maybe reboot some service or all server, by the way, this service should wait a long time to check if it run well, you'd better config 5 minutes sync at first, so we can quickly if the sync is good

  • Can you please elaborate your answer, with more detail and reference
    – Asad Refai
    Mar 20, 2017 at 5:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.