1

In my sharepoint 2013 test environment, I have 20 users and I found some of their properties are not sync with AD. I cannot find the resolution and I would like to try delete all user profiles, delete existing connection and rebuild, and start a full sync.

My sharepoint site also have My Site Host deployed. During above operation I will not change any AD users or groups. Maybe I know whether all the users' my site (their blog, following, etc) will be reserved? Beside, what other impact I should consider before perform the actions?

Thanks.

Mark

  • Have you tried sync'ing the user profiles with PowerShell first? Does Set-SPUser –Identity ‘<domain>\<username> –SyncFromAD –Web http://<name of web app> get the profiles to sync? – lwbecker2 Mar 24 '14 at 3:05
  • In Manage user profile page I can see "domain\mark" listed in active profiles. Then I run above command with domain\mark it return "Sp-User: you must specify a valid user object or user identity" – Mark L Mar 24 '14 at 3:24
  • 1
    Set-SPUser will only update the user property for the web (SPSite and all root webs) but not the user profile sync. If the problem is a bad sync the set-spuser would not resolve the issue. – Marco Scheel Mar 24 '14 at 7:53
1

If you delete the profiles you will loose the data stored in the profiles, but not the personal sites. Rather than delete the profiles, I would begin by recreating the connection. Then run a full import and troubleshoot the import with the MIISClient.

If that does not work you can then try more drastic approaches.

| improve this answer | |
  • Thanks. I think you have answered my question. Just one more follow up question. I modify the email field on AD for a user. But the sync never connection never aware the update. MIIclient report 0 for deltasync. What should I check? – Mark L Mar 25 '14 at 1:50
  • If you edited the field in AD and the UPS is not picking up the change I would ensure that you granted Replicating Directory Changes to the import account correctly. (If this is an answer can you mark it so? :)) – Matthew McDermott Mar 25 '14 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.