I am having a nightmare of a time with the SSRS/SP integration. Let me explain what I did.

First, we have:

  • 2 web front ends (WFE)
  • 1 App server
  • 1 DB server

I installed both SSRS components (Addin and Intergation mode) on a web front end (WFE)

Everything went great until I found out I can't scale it to the other WFE because we are using SQL Std Edition, so I uninstalled it

I installed both SSRS components on the app server

I couldn't get the service to register on the app server using Install-SPRSService. It executed with no errors, but the SSRS service app option didn't show up in CA

I ran the following that showed the service was provisioned:

Get-SPServiceInstance -all |where {$_.TypeName -like "SQL Server Reporting*"}

TypeName                         Status   Id
--------                         ------   --
SQL Server Reporting Services... Provi... 4b8c0711-3d2c-443b-b1e8-c58a8cb10cdd

Then I ran the following to find out where:



Wrong server, it was still provisioned to the WFE even though I uninstalled SSRS

I also ended up with a corrupt timer job pertaining to disabling SSRS, which caused an error when I tried to get into the timer job defs in CA.

I successfully deleted the timer job and was then able to access the job defs through CA again.

I reran the following and noticed the service instance was unprovisioned now. Yay!:

Get-SPServiceInstance -all |where {$_.TypeName -like "SQL Server Reporting*"}

TypeName                         Status   Id
--------                         ------   --
SQL Server Reporting Services... Unpro... 4b8c0711-3d2c-443b-b1e8-c58a8cb10cdd

But the service instance is still on the wrong server:



Before I take another step and hose it up all over again, what can I do to remove the service instance on the WFE? SSRS is already uninstalled from it. I might also add that the service does not show up in any of the servers, before or after I got it to an unprovisioned state. There should be nothing left on the WFE server.

Any help is appreciated!

  • Can you remove SPServices tag on this item... SPServices is a javascript client side library that abstracts the Sharepoint SOAP interface and does not seem to be associated with your item.
    – Paul T.
    Commented Mar 21, 2014 at 17:16
  • It must have been removed already. Commented Mar 25, 2014 at 12:12
  • Did you install these components on SQL server?
    – ShareApp
    Commented Jan 21, 2019 at 9:53

3 Answers 3


What I had to do was reinstall SSRS on the WFE and run uninstall cmds:

  • Install-SPRSService -uninstall
  • Install-SPRSServiceProxy -uninstall

Once I did this, I could install it on my app server.

Lesson: before you uninstall SSRS from a server, remove the service app first


I followed below steps.

get-spserviceinstance -Server |where {$_.TypeName -like "SQL Server Reporting Services Service*"} | Stop-SPServiceInstance

Go to program and feature and uninstall SQL Reporting Service from through SQL uninstall Wizard,

after installation, you can go to Central Admin and Check services on Server. it will be disappears from the server.

if you are familiar on powershell script. you can execute below command on the server where you want to stop the Service

get-spserviceinstance -Server localhost |where {$_.TypeName -like "SQL Server Reporting Services Service*"} | Stop-SPServiceInstance

on the new server

get-spserviceinstance -Server localhost |where {$_.TypeName -like "SQL Server Reporting Services Service*"} | Start-SPServiceInstance

After you execute this correctly. you need to perform IISReset on all Servers. which will redirect SSRS request to correct server. In Some cases, you have to restart all SharePoint Services available on Windows Services.


I had another problem , a dependency that prevent me to uninstall

i end up searching for it on the sharepoint config db

i run first

Get-SPServiceInstance -all |where {$_.TypeName -like "SQL Server Reporting*"}

get the id

and the run this query on sql

 SELECT * FROM SharePoint_Config . dbo . Dependencies WHERE ObjectId LIKE '%<ID FROM the previous powershell>%'


$Timerjob = Get-SPTimerJob -id <ID FROM THE DEPENDANTID COLUMN >


that do the trick

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.