1

[Using SharePoint 2013 Enterprise SP1]

I am trying to create a KPI in Dashboard Designer, and finding surprisingly little documentation for all its features. (Ok, maybe I'm pretty jaded and not that surprised.)

I have a Data Connection created which connects to a SQL Server Table, and that connection seems to be working properly. The table has 1 widget per record, with (among other things) a creation time field (shortdatetime), and a Pass/Fail field (bit). I want my KPI to be be "green" if, say, >95% pass in a given day, "yellow" if between 85%-95% pass, and "red" if <85% pass.

For the Number Format in the KPI, I have both Actual & Target using the Percentage format, 1 decimal place.

For Data Mappings, the Measure I am using for Actual is the Pass/Fail field from the Sql Server Table. I have 1 dimension: CreateDate.Day (I selected Year, Month and Day "Time Period Levels" back in the Data Connection, with my CreateDate field as the Master Time Dimension.) I set the dimension's default to be, say, yesterday. For Target, my Data Mapping is 1 (Fixed values).

For the Calculation column, I set Actual to Default (average) and for Target it is Default.

When I try to add this to a Scorecard, I just get Error for Actual and Target. Not sure where to go from here. Thanks for any pointers!

1

After some more searching and experimenting, I figured it out. I did not find any documentation for DD '13 but did find some for DD '10, which was "close enough" to translate to the newer version. Here are some relevant MS doc pages:
Walkthrough: Calculate normalized scores for KPIs
Configure data column properties
Configure time and aggregation settings

For my specific problem, here are the steps I took:

SQL Table
• Change the PassFail column from a bit to an integer which contains either 0 or 100 (instead of 0 or 1).

Data Source
• On the View tab, set all fields (other than the CreateDate and PassFail fields) to a Column Type of Ignore (this is in the Details pane).
• For the CreateDate field, set the Column Type to be TimeDimension. For the PassFail field, set the Column Type to Fact and the Aggregation to Average.

KPI
• Reset the Number Format for both Actual and Target to (Default).
• Change the Target Data Mapping from 1 to 100 (still Fixed value).
• In the Calculation column either Default or Data value will work.

That should do it! Now, on to filters...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.