2

I'm running stand-alone Sharepoint Foundation 2013, I want to be able to edit the name of a web part but cannot for the life of me find anyway of doing this. I also want to change the view of a webpart just on the one page e.g. I want a calendar webpart on my home screen only showing current events rather than the whole monthly calendar.

Any help would be great, it's probably really easy but I couldn't find anything on the subjects.

Thanks in advance.

  • Two different questions, first one can be done easily by going into Web Part settings.. Click the arrow that appears on the top right corner of the Web Part -> Edit Web Part.. It will display a panel on the left, where you can update the Title.. The second requirement will need some customization (AFAIK) – Arsalan Adam Khatri Mar 19 '14 at 17:09
2
  • To add a calendar with just the current events to a page, click the gear icon and you should see the Edit page option. It seems like SharePoint online's UI might be different from on prem. I've added an on prem screen shot to this step. On SP online go to the Page tab and select Edit.

enter image description here * Click the Insert then WebPart => Apps => Events where Events is the name of your calendar list.

enter image description here

  • Change the view clicking the downward arrow on the right of your screen. You might need to mouse over it to get it to be visible because MS only wants people who are initiated into the dark arts of SharePoint administration to find it.

enter image description here

enter image description here

  • Then change the value of Selected View to Current Events. If that view does not exist, you might have to create it.

    enter image description here

  • Then you expand the Appearance group (see image above) and you will see a Title attribute that you can change.

  • Are these features available in Sharepoint Foundation 2013? because i cannot for the life of me find the arrow (because unfortunately I'm not initiated in the dark arts). The only arrow i can select is a blue one that just minimises the web part. – Jack Cooper Mar 20 '14 at 9:26
  • If you can see the you don't have the correct permissions. – Robert Kaucher Mar 20 '14 at 11:27
  • I'm the site administrator, surely i don't need to grant myself permissions? – Jack Cooper Mar 20 '14 at 12:11
  • All of the options I mention are available in Foundation. Let's start at the beginning. Do you see the edit option when you click the gear icon? It seems SharePoint Online's UI is a little different. Click the gear, if you don't see edit you don't have design permissions. – Robert Kaucher Mar 20 '14 at 12:26
  • Yes I have edit page when clicking the gear in the top right hand corner. – Jack Cooper Mar 20 '14 at 12:30
1

For anyone experiencing the problem that I had (a blue arrow which only minimizes the web part) the way to resolve it is to add the site to compatibility view in Internet Explorer.

enter image description here

In IE11 go to settings > compatibility view

then have your site added like mine below:

enter image description here

this will then give you the correct view in which you can edit your web part.

  • That just seems odd. I'm using IE 11 as well. I can't imagine why it was behaving this way. – Robert Kaucher Mar 25 '14 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.