0

Just created a visual webpart as sandbox solution, didn't changed a word other then adding some text to visual webpart, tried to deploy it but getting this exception,

enter image description here

it is a single server with dc, sql and everything on it (SP 2013)

An attempt to connect to the remote activator failed with exception '

  • Did you find the ULS log entries about this error. Sandbox Solutions are launched through the process of SPUCWorkerProcess.exe (MSDN sandbox). – Nidhogg Mar 19 '14 at 8:08
  • Did you use Visual Webpart(Sandbox) or normal visual webpart.Normal visual webpart will not work in sandbox solutions. – Unnie Mar 19 '14 at 8:48
  • i also tried with webpart, same exception – Mathematics Mar 19 '14 at 11:57
3

Strangely enough, this fixes the problem for me on SharePoint 2013 instance installed on a Windows Domain Controller:

Set-SPLogLevel -Identity "SharePoint Foundation:Sandboxed Code Service" -TraceSeverity "Verbose"

Restart-Service -Name "SharePoint User Code Host"

Of course, I only use this in a non-production environment.

  • This helped me - I'm not sure why, though. – Nils Sep 14 '14 at 11:09
1

You can't run sandboxed code on a single server installation of SharePoint 2013 on Windows Server 2012 + domain controller. You can install and activate the solution without any problems, but any sandboxed code will throw the following error:

An unknown exception occurred while executing a sandboxed code solution request in the worker process.

Reference: http://www.jrjlee.com/2013/04/another-reason-to-stop-developing.html Check the comments of the link, there seems to be a workaround, I would not recommended it.

0

When you create a visual webpart, the ascx control file needs to be deployed to the physical path in controltemplates folder. However, sandboxed solutions cannot deploy the files to the physical path. This is one of the restrictions in Sandbox solutions.

  • i also tried with webpart, same exception – Mathematics Mar 19 '14 at 11:49
  • Is User code host service running? – Nadeem Yousuf Mar 19 '14 at 11:58
  • yes it is running very fast – Mathematics Mar 19 '14 at 12:02
  • 1
    pls tell me what speed it is running? – Richa Jain Dec 15 '14 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.