2

Today morning I was able to access the SP central administration site and all other SharePoint sites. Then, I created a new web application. Then, clicked on create new site collection. The 'create new site collection' form was open. I went for a cofee and came back after 15 mins and filled in the site collection name and hit 'OK' button to create this site colelction. It gave some correlation id and critical error 2aaf7e9c-46bb-80de-156d-16417c217c0b.

After this, I am unable to access any of SP site or central admin site.

I get the error as:

Info icon The webpage cannot be found HTTP 404

 Most likely causes: •There might be a typing error in the address. •If you clicked on a link, it may be out of date.

 What you can try:

Retype the address.

Go back to the previous page.

Go to and look for the information you want.

More information More information

This error (HTTP 404 Not Found) means that Internet Explorer was able to connect to the website, but the page you wanted was not found. It's possible that the webpage is temporarily unavailable. Alternatively, the website might have changed or removed the webpage.

For more information about HTTP errors, see Help.

I tried iisreset and also system restart. Still the same issue. However, if I enter the website URL as: http://<centraladmin url>/_layouts/15/settings.aspx then it opens up the settings page of central administration site.

Incase of a site if I enter the Sp siteurl in browser as: http://<siteurl>/. Then, it gives the same error 404 as pasted above. However, if I type in URL as http://<siteurl>/_layouts/15/viewlsts.aspx then I can see all the lists on that site. Then, if I click on say 'Site Pages' again it gives above pasted 404 error.

Any idea what is causing this issue?

SharePoint 2013 and SQL Server is on the same VM machine.

4
  • did you check the application pool is started in IIS?
    – Unnie
    Mar 19, 2014 at 6:27
  • Yes everything is started.
    – variable
    Mar 19, 2014 at 6:31
  • Any custom solutions in the farm? Mar 19, 2014 at 8:05
  • Yes, There are lot of custom solutions in the farm, they are present since 2 months now...
    – variable
    Mar 19, 2014 at 8:12

4 Answers 4

3

We ran the SharePoint 2013 Configuration Wizard and the central admin as well as the other sites are opening and working well.

0

When the _layouts folders work, that does not mean much, since they're not really inside t he web applications (CA, custom). They are virtual directories outside of these web applications. A good first thing to check if you can access any content that is located in the Content DB's (i.e. pages in site, list items etc).

One problem that may cause this (unlikely for CA) is that the welcome page for the site collection was not set or set to something that does not exist (check with _layouts/settings.aspx).

From experience, I learned the following thing may prevent SharePoint from running:

  • Services

    • On SP Servers
      • "Windows Process Activation Service",
      • "World Wide Web Publishing Service"
      • "SharePoint 2010 Administration",
    • On SQL Server
      • "SQL Server (MSSQLSERVER)",
      • "SQL Server Agent (MSSQLSERVER)",
  • SQL DB's

    • Check that any relevant SP Sql Databases are not corrupted or in a state other than online
  • App pools & IIS Sites
    • Check that the relevant app pools are running, same for IIS Sites
  • Web.config's of the virtual directories hosting the sites
    • Local_Drive:\Inetpub\wwwroot
14
  • 1. Central administration settings do not have a welcome.aspx page. This page exists only for the SP sites. Now, I went to this page for one of our sites and the value is: pcname:9898/SitePages/Home.aspx. If I copy/paste this into the URL the page opens up. However, when I type in pcname:9898, I get the same 404 HTML error. Do you get any hints on this?
    – variable
    Mar 19, 2014 at 8:38
  • 2. We are using SharePoint 2013 and all services except 'SQL Server Agent' are running. I remember that 'SQL Server Agent' was never running. I checked on other systems which have SharePoint server installed. They too have 'SQL Server Agent' as not running.
    – variable
    Mar 19, 2014 at 8:40
  • 3. How do I check for "whether SP Sql Databases are not corrupted or in a state other than online"?
    – variable
    Mar 19, 2014 at 8:41
  • 4. Relevant app pools are running
    – variable
    Mar 19, 2014 at 8:41
  • 5. What do I look for in the web.config?
    – variable
    Mar 19, 2014 at 8:41
0

Please check if you have global directory exists and all its file in it on the server. it should be located at ed both "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Template\gobal. If it is not exist copy it from another app/wfe server and paste it here.

Rahul

0

Run the wizard to reconfigure config data base in wfe that hosts the central admin site .This was the solution for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.