0

I'm trying to upgrade a webApp from 2007 to 2013. Following this tutorial: Tutorial The migration process to 2010 works perfectly . But When I try to do the same process to 2013, it breaks on 30% and the powershell returns me the error "cannot upgrade the ContentDatabase"

On LOG file I found the follow logs:

03/17/2014 18:47:40.81  powershell (0x2304) 0x229C  SharePoint Foundation Upgrade   SPUpgradeSession    ajxp5   INFO    SPContentDatabase Name=cnt-modulistica-9095 f2a76a53-fba2-4c07-bd1c-af21e91408ab
    03/17/2014 18:47:40.81  powershell (0x2304) 0x229C  SharePoint Foundation Upgrade   SPUpgradeSession    ajxp5   ERROR   Received exception when querying for WebTemplate ID 1 (Name: , lcid: 1040), provisioned in ContentDatabase cnt-modulistica-9095: System.ArgumentException: File or arguments not valid for site template ''.  Parameter name: WebTemplate     at Microsoft.SharePoint.SPWebTemplateCollection.get_Item(String strKey)     at Microsoft.SharePoint.Upgrade.SPSiteWssSequence.GetWebTemplates(Boolean fRootWebs, SPContentDatabase contentDatabase, SPWeb web, SPUpgradeSession session). f2a76a53-fba2-4c07-bd1c-af21e91408ab
    03/17/2014 18:47:40.81  powershell (0x2304) 0x229C  SharePoint Foundation Upgrade   SPUpgradeSession    ajxp8   INFO    SPContentDatabase Name=cnt-modulistica-9095 f2a76a53-fba2-4c07-bd1c-af21e91408ab
    03/17/2014 18:47:40.81  powershell (0x2304) 0x229C  SharePoint Foundation Upgrade   SPUpgradeSession    ajxp8   WARNING WebTemplate ID 1 (Name: , lcid: 1040), provisioned in ContentDatabase cnt-modulistica-9095, is missing. f2a76a53-fba2-4c07-bd1c-af21e91408ab
    03/17/2014 18:47:40.82  powershell (0x2304) 0x229C  SharePoint Foundation Upgrade   SPUpgradeSession    ajxp5   INFO    SPContentDatabase Name=cnt-modulistica-9095 f2a76a53-fba2-4c07-bd1c-af21e91408ab
    03/17/2014 18:47:40.82  powershell (0x2304) 0x229C  SharePoint Foundation Upgrade   SPUpgradeSession    ajxp5   ERROR   Received exception when querying for WebTemplate ID 1 (Name: , lcid: 1040), provisioned in ContentDatabase cnt-modulistica-9095: System.ArgumentException: File or arguments not valid for site template ''.  Parameter name: WebTemplate     at Microsoft.SharePoint.SPWebTemplateCollection.get_Item(String strKey)     at Microsoft.SharePoint.Upgrade.SPSiteWssSequence.GetWebTemplates(Boolean fRootWebs, SPContentDatabase contentDatabase, SPWeb web, SPUpgradeSession session). f2a76a53-fba2-4c07-bd1c-af21e91408ab
    03/17/2014 18:47:40.82  powershell (0x2304) 0x229C  SharePoint Foundation Upgrade   SPUpgradeSession    ajxp8   INFO    SPContentDatabase Name=cnt-modulistica-9095 f2a76a53-fba2-4c07-bd1c-af21e91408ab
    03/17/2014 18:47:40.82  powershell (0x2304) 0x229C  SharePoint Foundation Upgrade   SPUpgradeSession    ajxp8   WARNING WebTemplate ID 1 (Name: , lcid: 1040), provisioned in ContentDatabase cnt-modulistica-9095, is missing. f2a76a53-fba2-4c07-bd1c-af21e91408ab
    03/17/2014 18:47:41.06  powershell (0x2304) 0x229C  SharePoint Foundation Upgrade   SPManager   aj26w   INFO    No context object   f2a76a53-fba2-4c07-bd1c-af21e91408ab
    03/17/2014 18:47:41.06  powershell (0x2304) 0x229C  SharePoint Foundation Upgrade   SPManager   aj26w   ERROR   Upgrade session failed due to unexpected exception: Microsoft.SharePoint.SPException: Site http://win-obhlei0s9dt:9095 cannot be upgraded.     at Microsoft.SharePoint.SPSite.StartUpgradeBypassAllowUpgradeCheck(SPSiteUpgradeType upgradeType, Boolean queueOnly, Boolean consoleOutput, Boolean throwIfUpgradeNotNeeded, Boolean sendEmail, Boolean checkConcurrentSiteUpgradeSession)     at Microsoft.SharePoint.SPSite.Upgrade(Boolean recursively)     at Microsoft.SharePoint.Upgrade.SPUpgradeSession.ReflexiveUpgrade(Object o, Boolean bRecurse)     at Microsoft.SharePoint.Upgrade.SPUpgradeSession.Upgrade(Object o, Boolean bRecurse)     at Microsoft.SharePoint.Administration.SPPersistedUpgradableObject.Upgrade(Boolean recursively)     at Microsoft.SharePoint.Administration.SPDatabase.Upgrade(Boolean recursively)     at Microsoft.SharePoint.Administration.SPContentDatabase.<>c__DisplayClass2.<Upgrade>b__0()     at Microsoft.SharePoint.SPSecurity.RunAsUser(SPUserToken userToken, Boolean bResetContext, WaitCallback code, Object param)     at Microsoft.SharePoint.Administration.SPContentDatabase.Upgrade(Boolean recursively)     at Microsoft.SharePoint.Upgrade.SPManager.RunUpgradeSession(Object lockObject, IUpgradable iup, SPUpgradeOperationFlags upgradeOperationFlags).   f2a76a53-fba2-4c07-bd1c-af21e91408ab
  • 1
    Lookalike you have a template webtemplate 1( i think in Italian language) is missing on the 2013 farm. Make sure that template deployed to the 2013 farm and then run upgrade. But if you dont want use it then clean it in 2007 then run the upgrade it. – Waqas Sarwar MVP Mar 18 '14 at 17:39
  • Did you ever find a solution to this problem? I'm having the same error at 30% of migration. Thanks in advance. – user31423 Jul 10 '14 at 11:08
  • I have the same issue. So if you found a solution to this I would really appreciate a small hint. – tschuege Jul 15 '15 at 14:32
  • waqas-sarwar-mcse's answer worked for me. Maybe you have a language template installed in your content DB – hello B Jul 15 '15 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.