0

Does SPLongOperation overrides setting of executionTimeout in layouts/web.config for sharepoint 2010 standalone/farm and 2013 standalone?

As I have a long running process which works fine in a standalone SharePoint 2010 farm and a standalone 2013 Farm. But does not work as expected in a 2013 farm environment where SPLongOperation does not seem to override the Web.config executionTimeout and a thread abort exception is thrown. Even when the process is running inside SPLongOperation.

2
  • Where does it not work ? Because you say it works both on 2010 and 2013 :)? Or is the difference in Farm vs single server install? Mar 14, 2014 at 14:22
  • sp2013 farm environment .it does not work Mar 17, 2014 at 14:14

1 Answer 1

0

You have to change the settings on IIS

IIS -> Application Pool -> Advanced Settings -> Process Model -> Shutdown Time Limit (seconds)

3
  • any difference from sharepoint 2010 environment as it works as expected there? Mar 14, 2014 at 11:12
  • I had this problem on Central Administration site, and I had to change the application pool timeout. All the other ways fail.
    – Nico
    Mar 14, 2014 at 11:15
  • this is on sharepoint site and it works perfectly on sharepoint 2010 with same iis settings.only fails on sp2013 farm environment. Mar 14, 2014 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.