8

I configure a SharePoint 2013 site using the web interface. I save the site as a template, a WSP package. I then utilize this template on new, clean, team sites.

It works great almost all the times.

However, a few times, I get an error message about corrupt xml in the package. The error message tells me that the attribute $Resources:core,True_Unless_Jpn; isn’t valid, it should be a simple true or false. The localized string isn’t being managed correctly.

I can’t see any signs of any other localization problems or other problems in general.

The error remain within the same web application until I do one or sometimes several IISResets or recycles of the application pool. After this everything may work great for a few days or months until the error appear once again.

The application pools are recycled automatically every night and my best guess is that something goes wrong from time to time, causing problems to the localization.

All ideas are appreciated.

Thanks!

  • Was the language pack installed correctly? Are there any errors in ULS logs? – luccio Apr 11 '14 at 8:17
  • Please let me know if you received a solution - I am having the exact same problem you are describing. – user25358 Apr 24 '14 at 13:01
  • We have installed one additional language pack and I haven’t seen any other problems indicating a problem with it. No other problem or log entry indicate any problems. The sites we were trying to provision while getting this problem were English sites. The only error I have found in the ULS logs is the error message described in my original post. Unfortunately no additional clues or solution yet. We haven’t seen the problem in a while but if it re surface we will probably create a Microsoft case and try and see if they can help us get a better understanding of the problem. – Daniel Estelius Apr 25 '14 at 12:17
  • Have you gotten the same error again? Since now I'm having the same problem.. – Random IT Guy May 22 '14 at 8:21
  • No, not recently. Please share if you will find anything interesting. – Daniel Estelius May 22 '14 at 12:24
1

Going further in the logs and in the template file, i noticed that the columns using this $Resources:core,True_Unless_Jpn; are located in the following content types:

<ContentType ID="0x0116" Name="East Asia Contact"

<FieldRef ID="{fdc8216d-dabf-441d-8ac0-f6c626fbdc24}" Name="LastNamePhonetic" Required="FALSE" Hidden="$Resources:core,True_Unless_Jpn" />
<FieldRef ID="{ea8f7ca9-2a0e-4a89-b8bf-c51a6af62c73}" Name="FirstNamePhonetic" Hidden="$Resources:core,True_Unless_Jpn" />
<FieldRef ID="{034aae88-6e9a-4e41-bc8a-09b6c15fcdf4}" Name="CompanyPhonetic" Hidden="$Resources:core,True_Unless_Jpn" />

and

<ContentType ID="0x0106" Name="Contact"

<FieldRef ID="{fdc8216d-dabf-441d-8ac0-f6c626fbdc24}" Name="LastNamePhonetic" Required="FALSE" Hidden="$Resources:core,True_Unless_Jpn" />
<FieldRef ID="{ea8f7ca9-2a0e-4a89-b8bf-c51a6af62c73}" Name="FirstNamePhonetic" Hidden="$Resources:core,True_Unless_Jpn" />
<FieldRef ID="{034aae88-6e9a-4e41-bc8a-09b6c15fcdf4}" Name="CompanyPhonetic" Hidden="$Resources:core,True_Unless_Jpn" />

After removing those columns from those content types i haven't experienced problems so far

  • This section is for answers only. Please edit your original post to add more information. – Robert Lindgren Feb 2 '15 at 15:19
0

Verify your core resource file at following location:

C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\Resources

See if you can find entry for "True_Unless_Jpn". If not, create one and save.

Hope this helps!!

0

I ran into the same problem when adding solutions to a newly created site collection.

Adding a sleep of 30 seconds between the site creation and the installation of solutions resolved the issue.

For more details see my blog post:

https://veenstra.me.uk/2018/10/01/sharepoint-long-running-powershell-migration-scripts-fail-on-install-spusersolution/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.