3

Hello I'm new on Office 365/SharePoint 2013 Apps development, as first test project I have created an Outlook App (Mail app for Office), I didn't edit the simple code generated by NAPA, normally it will work, but when I deploy the app I get this error :

App Error Something went wrong and we couldn't start this app. Please try again later or contact your system administrator.

enter image description here

After some debugging, via the F12 Tools, I find that the https://appsforoffice.microsoft.com/lib/1.0/hosted/office.js is not available! Is there a solution for this problem ?

EDIT : The site is available over http but not over https, then I tried to use it but it still not working:

The page at 'https://grindi-81a84eec62----.sharepoint.com/FirstMailApp/App/Home/Home.htm…#path=/mail' was loaded over HTTPS, but ran insecure content from 'http://appsforoffice.microsoft.com/lib/1.0/hosted/office.js': this content should also be loaded over HTTPS.

  • Hey I had the same issue with my computer. I wasted my time on it for many days but finally I got a solution from this link microsoftliveassist.com/… – user29735 Jun 17 '14 at 9:26
0

SOLVED : the issue is only happen when I debug my app in Napa, and at the same time I'm signed in to MSDN sites. If I logout from the MSDN, the issue is solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.