I'm using VS2013 for developing SharePoint Hosted App against a 365 development site. The VS debugger tool doesn't hit anymore my breakpoints. It used to the day before. I have made many tests,

  • On the "Hello World" sample (with a breakpoint on a simple alert()).
  • On two different desktops.

Can someone help me to solve that question ?


1 Answer 1


Sounds like you accidentally changed the code in such a way that its not running to the line you have your break point at. If you edit the post with your code I can look at it for you.

  • Thanks Mike. I tried again this morning on my sharepoint basic app (OOB) and it's now debugging. Also on my more complex app. I don't understand why. Seems not to be relied on code. May be relied on the linked between VS and browsers ? Commented Mar 10, 2014 at 18:16
  • VS is a great tool, but it does have some strange stuff you have to watch out for. I've had to completely recreate projects because it seems to cache certain things that I can't circumnavigate. Glad it all worked out. Commented Mar 10, 2014 at 22:05
  • You are right. In fact, for now, debug issue is coming back. I'm unable to hit breakpoints anymore. Mistery... Commented Mar 17, 2014 at 13:19
  • Its unfortunate that you're getting these issues with VS2013, '13 is a HUGE improvement on '12 as far as performance goes. Occasionally when I do run into issues like this and I can determine 100% it isn't my fault then usually (emph. usually) closing and reopening VS resolves it. Commented Mar 17, 2014 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.