1

I´m on SharePoint 2010, IE10

"Connect to Outlook" Button is disabled on blog post list. I noticed, that in some type of Lists this option is disabled even if site feature "Offline Synchronization for External Lists" is activated.

I know of workarounds like set up an alert or RRS Feed. Is there a reason why this option is disabled by default?

Thank You!

1

It is related to "Minimal Download Strategy":

The reason why the "Connect to Outlook" is greyed out, is because there is a feature called "Minimal Download Strategy". The feature redirect you to an application page start.aspx, do some validation, and loads start.js script. This add the "_layouts/15/start.aspx" in the URL wich seems to break the Connect To Outlook functionnality.

To go arround this, you have 2 choice;

1-Open you Calendar, Click the Calendar button in the top navigation bar, and go to "List Settings". (4 buttons right from the connecto to outlook)

From there, copy the "Web Adress", and paste it in the adress bar of your browser.

Then go to the Connect to Outlook, it shouldn't be greyed out anymore. It work for me on IE9 32bit with outlook 32 bits.

2- Go to the site settings of your collection, then to Manage Site Features, and deactivate the Minimal Download Strategy" feature.

The Minimal Download Strategy is actually a very good feature that you migh want to keep though as it makes most of the apps load faster.

I still don't know why this breaks it, but I'll do more research on it.

Let me know if this works for you as well.

Reference

http://social.technet.microsoft.com/Forums/sharepoint/en-US/0ece1634-002b-4371-96ba-3a6c697d3694/connect-to-outlook-disabled?forum=sharepointgeneral

  • Hi sorry I forgot to write, that I´m on SP2010. 1 Option: Does not work for me. 2 Option does not fit to SP2010 .......I´m talking about the posts lists on a SP Blog, where you can manage blog posts. – user21399 Mar 6 '14 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.