I'm looking for a solution to this in my 2013 farm.

TITLE The server farm account should not be used for other services.

EXPLAINATION spadmin, the account used for the SharePoint timer service and the central administration site, is highly privileged and should not be used for any other services on any machines in the server farm. The following services were found to use this account: SharePoint - spsite.health.org80 (Application Pool) Distributed Cache Service(Windows Service)


3 Answers 3


I don't agree with the proposed solution of managing this in CA. Dist. Cache should be managed via PowerShell. Here's what I've used:

Change Managed Account for Distributed Cache: https://technet.microsoft.com/en-us/library/jj219613(v=office.15).aspx?tduid=(e9e5627e7621eb82445b7c770990f515)(256380)(2459594)(TnL5HPStwNw-c56boHDL15BolsSmw_oyhg)()#changesvcacct

Add-PSSnapin Microsoft.SharePoint.PowerShell -EA 0
$farm = Get-SPFarm
$cacheService = $farm.Services | where {$_.Name -eq “AppFabricCachingService”}
$accnt = Get-SPManagedAccount -Identity "Domain\ManagedAccount"

##Change AppFabric Account
$cacheService.ProcessIdentity.CurrentIdentityType = “SpecificUser”
$cacheService.ProcessIdentity.ManagedAccount = $accnt

This runs for ~10 minutes - Be patient and don't close this until complete

(looks like the "#" were left off the PS1 copy/paste.


Fire up your Central Administration -> Security -> Configure Service Accounts

Locate the App Pools for:

SharePoint - spsite.health.org80 (Application Pool) Distributed Cache Service(Windows Service)

Change these 2 application pools to a managed account with fewer privileges (if you need more help setting up a managed account, there is information out there on how to do so).


It solved to remove user from farm admin group which configure for service account

  • I get a similar error, but my account is just a Domain user and is not in the local administrators group.
    – Rick
    Commented Sep 6, 2016 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.