7

When I tried installing SharePoint Server 2013 I retrieve a error message:

Windows Server Appfabric is not correctly configured. your should uninstall Windows Server Appfabric and reinstall it using the SharePoint Products preparation Tool"

In this situation I didn't know what to do and then I downloaded and installed "Windows Server Appfabric" (http://www.microsoft.com/en-us/download/details.aspx?id=17616) and "Cumulative Update package 1" (http://support.microsoft.com/kb/2671763/sv)

Again I tried installing SharePoint server 2013, same error message occur.

  • What should I do?

  • What is "SharePoint Products preparation Tool" Where can I retrieve it?

1

I have configured a plenty of SharePoint Servers and a many services on them but there is one server where I am unable to since November, 2017 just because of the same AppFabric issue.

I wish, if I find someone generous enough to come over a screen share troubleshoot session and resolve my problem.

I would be very thankful to him/her.

0

What is "SharePoint Products preparation Tool"? Where can I retrieve it?

The SharePoint Products preparation Tool is also known as the "Prerequisites Installer". It comes as far as I know with every installation image of SharePoint Server and installs all server-specific software requirements amongst others Windows AppFabric and configures the Windows Server (activating all necessary roles and features).

What should I do?

Try to start the Prerequisites Installer from your installation medium before you try to install the SharePoint Server.

In case you have no internet connection, then you can install the necessary software requirements manually. The following links should give you a good introduction to that:

0

It's often error when You try to install some versions that are "not fully supported", example on 2012 R2 or Windows 8. But this could be solved

1) Download all prerequisites, for automatization You can use ps script like from here(click Properties-> “Unblock” on ps1 file before use): https://gallery.technet.microsoft.com/office/DownloadInstall-SharePoint-e6df9eb8

2) Extract all files from sharepoint ISO to some folder, example "C:\SharepointInstall\", and put download prereqs to "C:\SharepointInstall\prerequisiteinstallerfiles\" (FilterPack file should be near)

3) Then put there cmd file, by example "mysetup.cmd", in root "C:\SharepointInstall\", and edit it like

prerequisiteinstaller.exe
/SQLNCLi:prerequisiteinstallerfiles\sqlncli.msi
/PowerShell:prerequisiteinstallerfiles\Windows6.1-KB2506143-x64.msu
/NETFX:prerequisiteinstallerfiles\dotNetFx45_Full_x86_x64.exe
/IDFX:prerequisiteinstallerfiles\Windows6.1-KB974405-x64.msu
/Sync:prerequisiteinstallerfiles\Synchronization.msi
/AppFabric:prerequisiteinstallerfiles\WindowsServerAppFabricSetup_x64.exe
/IDFX11:prerequisiteinstallerfiles\MicrosoftIdentityExtensions-64.msi
/MSIPCClient:prerequisiteinstallerfiles\setup_msipc_x64.msi
/WCFDataServices:prerequisiteinstallerfiles\WcfDataServices.exe /quiet
/KB2671763:prerequisiteinstallerfiles\AppFabric1.1-RTM-KB2671763-x64-ENU.exe

Run it as administrator and install

0

[Solved] Kindly, follow the mentioned steps in this article to configure windows server AppFabric correctly
https://mohamedelkassas.wordpress.com/2014/06/14/windows-server-appfabric-is-not-correctly-configured-as-sharepoint-2013-prerequisites/

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 1
    Quote the main aspects of the article as links tend to go down. – Paul Strupeikis Feb 15 '16 at 12:54
  • Please don’t add just a link as answer to a question. If the link breaks, the answer you provided will not be useful for future visitors. Provide an answer of your own and use the link as reference. If needed, you can block quote the content from your link. More information is found in our help center, especially How do I write a good answer – Benny Skogberg Feb 15 '16 at 13:17
0

The main reason for its failure is that windows app fabric should not be installed by double clicking.

I learnt this lesson during installation and configuration of our farm.

Please uninstall appfabric completely. And also try to remove the registry after that use commands to install the app fabric.

Then check for SharePoint installation and then you'll be good to go

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.