I'm adding a content query in the master page and every time I will customize it returns the following error:
Error SPD 2013

Someone could help me or explain me why this error happens?

I tried doing the content query in a page layout and the same error happens.

  • 3
    I think you have to check the ULS log for that Correlation ID. – eirikb Feb 27 '14 at 20:18
  • I looked at the log and returned error is very generic, impossible to identify where the problem really this – luanna.iozzi Feb 27 '14 at 20:25
  • 2
    As generic as it may be, your problem is very hard to solve without as much information as possible :) like what query are you using? What customizations are made in the farm? And so on – Robert Lindgren Feb 27 '14 at 21:01
  • We do need some more info. Could you maybe add some of your code/steps you did to configure it? It might help us help you out. – Robert Kaucher Feb 27 '14 at 21:12
  • You can try iisreset – SharePointMan Feb 28 '14 at 4:43

I followed these steps and managed to solve the problem. Thanks guys

Content Query Web Part Key cannot be null

Very useful error message!!!! There is a conflict with the Developer Feature in SharePoint 2013 which appears to break the content query web part. Not so hot if you are relying on using this web part on your development site where you need the development feature to be available.

To resolve this issue you will need to disable the feature, unfortunately it is a hidden feature so you will need to disable this via SharePoint 2013 management shell. The powershell script below should help, run this, it will disable the SharePoint 2013 developer feature and Viola you have a working Content Query web part.

------- Start disable developer feature command -------------

Disable-SPFeature -identity "E374875E-06B6-11E0-B0FA-57F5DFD72085" -URL http://yoursiteurl

------- Endable developer feature command -------------

Once you have configured your content query web part you can re-enable the developer feature if required using the script below.

------- Start enable developer feature command -------------

enable-SPFeature -identity "E374875E-06B6-11E0-B0FA-57F5DFD72085" -URL

http://yoursiteurl ------- End enable developer feature command

Hopefully we will see a fix in the next Cumulative update for this issue, I'm sure there will be more.

  • 2
    I'm glad you found the solution, link only answers are typically frowned upon. I've taken the liberty to copy the pertinent part of the related blog post into your answer so it doesn't get lost. – Eric Alexander Feb 28 '14 at 19:20

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.