8

I was editing the Seattle Master Page and suddenly my site got stuck in the "Preview Page" mode:

enter image description here

And I don't know how to stop it. I returned back the template to the original Seattle template but the top bar is still present.

I tried this solution without any luck and I don't want to rollback the entire site.

  • Isn't your page in preview mode, instead of the master page? Please check if the page has been checked out, or is in a draft version and perhaps revert it to the previous published version instead. – Jasper Mar 4 '14 at 9:38
  • i copied the master page (from another site) and is still stuck in preview page mode – magallanes Mar 4 '14 at 11:29
  • check if you have changed the default master page. – SharePointMan Mar 5 '14 at 6:54
  • Please has anyone solved this issue? I'm having the same issue. Opening version history in designer doesn't work...it says server is busy. Trying it from within SharePoint doesn't solve the problem either. Any help would be appreciated...thanks. – user31563 Jul 15 '14 at 14:52
3
+25

In the _catalogs/masterpage/ find the seattle.master. Select Version History and select restore on the first published version of the masterpage.

enter image description here

When restored, go to the library settings of the masterpage gallery, select versioning settings and select “Create major versions” in the Document Version History section, and in the Require Check Out section select No. That way all your changes will immediately appear when you do design changes. No need for check-in, publish and approve in your development environment.

enter image description here

  • This solution does not work at all, i have try in my orginal project and in a test one. – mejiamanuel57 Feb 20 '15 at 19:13
1

OK, i had 5 days with this problem, so i called a master in sharepoint and this was the solution:

Imagine your intranet url is: contoso.com/intranet/portal so type in your browser contoso.com/intranet/porta/Pages/default.aspx

Now you have acces to your Intranet, but we haven't finish yet.

Once inside your intranet go to site settings ->Look and Feel -> Welcome Page. Just type contoso.com/intranet/porta/Pages/default.aspx

That all!

0

Try these:

  • After reverting it back to the original template, check-in > publish > check out to edit again > save. Refresh the page.
  • If you have access in Sharepoint Designer, set the seattle.html the homepage enter image description here

These worked for me before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.