1

Can anybody help?

I have a document library that contains a filter of relevance and I tag the documents against the relevance and then add a search results webpart to a page, initially it works fine and all documents that I have tagged are there but when I add new documents they do not show?

The Document Library has no version control and no check in- check-out enabled

I have been reading up on the problem and I gone through the trim duplicates which’d worked on documents that were already in the document library

  1. Export the Search Results Web Part from your page.
  2. Open the .webpart file in your favorite editor.
  3. Search for “Trim Duplicates”, you will find it as part of the DataProviderJSON property.
  4. Set the Trim Duplicates property to False.
  5. Upload the web part.
  6. Add the web part to your page. Which is really helpful but is still doesn't work for adding new documents??

Is there anything else I can try?

  • 1
    The thing with search is that it needs to do a crawl before new content will be indexed and searchable – Robert Lindgren Feb 26 '14 at 14:40
  • You could check your content source and check if your files have been crawled yet (central admin -> application management -> service applications -> your service application -> crawl log) – Cameron Verhelst Feb 26 '14 at 14:48
  • thanks all I set it up for continuous crawling and it has succeeded on full crawls last night so i have started a full crawl again, i have also checked the content source and my local SharePoint sites have completed, i have also gone through the logs and there are no errors regarding any of the recent documents that have been added to the document library? thanks again for your help with this, it is doing me in!!!! – jakes Feb 26 '14 at 15:21
5

The thing with search is that it needs to do a crawl before new content will be indexed and searchable.

Also the search does not crawl Drafts, so you would have to publish major versions of the documents before they will be indexed by the next crawl.

Another thing to check is the Draft Item security, it should be set to 'Any user who can read items'.

You can also try to force a reindexing of the library from the Advanced settings of the library

  • Thanks Robert, but this document library is for read only documents with no version control of check out/in upon it, i have full control and the documents are visible in the all document section, the relevance i have set up is a look up from list in the root site and all the other documents seem to be ok, just new documents?? thanks again – jakes Feb 26 '14 at 15:25
  • Make sure you have performed a crawl since you have added the documents. The All Items list is not based on search, so it will show them anyway. Also your question is written as there is versioning and check-in /-out enabled. – Robert Lindgren Feb 26 '14 at 15:27
  • I have edited your question to correct that last fact. – Robert Lindgren Feb 26 '14 at 15:27
  • Hey Robert, I have disabled the check documents out section for the document library and there is no version control on that document library – jakes Feb 26 '14 at 15:30
  • 2
    So you tell me, but you have still not answered if you have performed a new search crawl since you added the documents. – Robert Lindgren Feb 26 '14 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.