I am facing below error. I have created web part in SharePoint 2010 solution and deploying that web part in Sharepoint 2013 Foundation. After I install webpart I face bellow error in central administrator.

[MissingSetupFile] File [Features\4Project\ChangePassword\ChangePassword.webpart] is referenced [1] times in the database [WSS_Content_5000], but exists only under Microsoft SharePoint Foundation 2010 setup folder. Consider upgrading the feature/solution which contains this file to the latest version. One or more setup files are referenced in the database [WSS_Content_4500], but are not installed on the current farm. Please install any feature or solution which contains these files.

  • did you try to install the solution with compatibility mode, try this and see the behavior...Install-SPSolution -Identity contoso_solution.wsp -GACDeployment -CompatibilityLevel {14,15}....You can use 14 or 15 or even both
    – Waqas Sarwar MVP
    Commented Feb 26, 2014 at 14:29

2 Answers 2


As the warning suggests you need to update the solution created for SP 2010 to be compatible with SP 2013. For that you need to convert the VS 2010 project to VS 2012/2013. Main things which need to be upgraded are Dot Net framework, assembly versions, reference to /_layouts/, ~/_CONTROLTEMPLATES More info here.

  • Hi,But I do not want to upgrade solution because my same webpart is working on both 2010 and 2013 server. So I can't update my solution. Commented Feb 26, 2014 at 10:37
  • The webpart will work in SP 2013 only in sites which run in SP 2010 mode and not in SP 2013 sites. Commented Feb 26, 2014 at 10:58

The simplest way would be to deploy the WSP package in both compatibility modes: 14 (2010) and 15 (2013).
This requires the solution deployment to be done from PowerShell (not the CA) with a command such as:

Install-SPSolution -Identity <solution_name> -GACDeployment -WebApplication <Web_app_URL> -CompatibilityLevel "14,15"

Or add the -force parameter if you don't want to uninstall first:

Install-SPSolution -Identity <solution_name> -GACDeployment -WebApplication <Web_app_URL> -CompatibilityLevel "14,15" -force

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.