I'm creating a custom WebTemplate. I added the following NavBars to the template:

    <NavBar Name="SharePoint Top Navigation Bar" Url="" ID="1002" />
    <NavBar Name="Home" ID="1031" />
    <NavBar Name="Project Documents" Url="Lists/ProjectDocuments" />
    <NavBar Name="Project Tasks" Url="Lists/Tasks/AllItems.aspx" />
    <NavBar Name="Recent" ID="1033" />
    <NavBar Name="Site Contents" ID="1034" />

The resulting site has Site Contents twice.

enter image description here

Removing the NavBar element for Site Contents results in only one Site Contents link being rendered, however it is the one below the Edit Links button.

Any tips for fixing the location and/or removing the duplicate?

3 Answers 3


I found an easy solution with no need to change navigation style.

In the page layout HTML file find

<div class="ms-core-listMenu-verticalBox">

add a style="display:none".

The second (and further... I had sometime 2 "site contents" links there...) and ONLY that one will disappear, keeping save the other links in the quick launch menu (I have tested both in on premise and 365).


you have two options:

  1. hide "edit links" with js / css

  2. Switch from "Managed Navigation" to "Structural Navigation" in ~/_layouts/15/AreaNavigationSettings.aspx


call the following css overwrite:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.