0

I am using Sharepoint 2013 Online.

I have the following code using the /_vti_bin/lists.asmx web service

  XmlDocument camlDocument = new XmlDocument();
            XmlNode camlNode = camlDocument.CreateElement("Query");

            StringBuilder sb = new StringBuilder();

            sb.Append("<Where>");
            sb.AppendFormat("<Eq>");
            sb.AppendFormat("<FieldRef Name='Individual' />");
            sb.AppendFormat("<Value Type='Lookup'>John Doe</Value>");
            sb.AppendFormat("</Eq>");
            sb.Append("</Where>");

            camlNode.InnerXml = sb.ToString();
            int rowlimit = 2000;


            XmlNode items = myService.GetListItems("Documents", null, camlNode, null, rowlimit.ToString(), null, null);

and when I run it I am getting the following error message:

The attempted operation is prohibited because it exceeds the list view threshold enforced by the administrator.0x80070024

The list Documents has 50,000 records. However there is only 90 that have a record that has the individuals name John Doe.

It should be able to return the 90 records? Or can I not query any list that has more than 5000 records?

1

You need to either increase the List View Threshold or disable resource throttling on the list.

  1. Navigate to Central Administration.

  2. Go to Application Management > Manage Web Application and click on your web application to select it.

  3. In the Ribbon, click on General Settings drop-down and choose “Resource Throttling”.

  4. In the “List View Threshold”, increase the value (by a factor of 2, for example) and click OK.

  5. Try to replicate the error. If the error persists, increase the value again until the error goes away.

Or use PowerShell to disable resource throttling.

SPList.EnableThrottling = $false

References: http://sharepointnomad.wordpress.com/2011/05/04/solving-the-attempted-operation-is-prohibited-because-it-exceeds-the-list-view-threshold-error/ http://sharepointnadeem.blogspot.com/2012/02/attempted-operation-is-prohibited.html

  • I am using Sharepoint Online (Office 365) It can not be changed on this version :( – Michael Feb 25 '14 at 5:35
  • Then you may need to Split the items into multiple lists so that no list exceeds 5,000 items. support.microsoft.com/kb/2759051 – Nadeem Yousuf Feb 25 '14 at 5:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.