I have a user profile that has fields from multiple sources. fields form AD and fields from BCS -> SQL DB. Everything is working, except if the DB is down, the fields get populated with empty data. However this is not the behavior I am looking for, I want to sync and if one of the sources is down, the current data is shown and not empty fields. I have been banging my head against the wall to this to work, in FIM and I can get one thing working or the other... it either updates or it does not update any changes if I disable Allow Null (from configure attribute flow).

How can I do this?

EDIT: My setup-up is similar to: http://blogs.msdn.com/b/momalek/archive/2011/02/06/sharepoint-2010-user-profile-service-part-4-configure-ups-synchronization-sources.aspx#comments

A Filter in the syncronization, some sort of rule? I am a bit lost

  • Could you post some more detail regarding the environment? How did you set up the connection, etc in the profile? Commented Feb 24, 2014 at 21:05
  • Sure the data is populated by a sync process, the sync process calls a BDC object that has a ReadItem(id) that updates the fields. The problems that i am having is detecting that the database is not accessible, and when it's not accessible to stop the overwrite of the fields. Ill post a screenshot of the process tomorrow, it's in a VM. i believe this can be fixed in the FIM Join or something like that, because I have not found a way using code to do this...
    – Astronaut
    Commented Feb 24, 2014 at 22:28
  • Always is possible to create a BDC in .Net as a wrapper to sql server. However, it requires to know how to program it and the whole operation is not trivial.
    – magallanes
    Commented Feb 26, 2014 at 21:25

1 Answer 1


A workaround -- configure the UP sync process to be disabled. Then write a process to check the remote source. If the source is available, enable the UP sync.

  • hum yeah, not sure how I would do that. I have 4 days experience with sp
    – Astronaut
    Commented Feb 28, 2014 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.