1

I was wondering if this has happened to anyone and if anyone can suggest a fix is.

| SharePoint 2010 | Top level site | Administrator permissions

I had a number of BCS connections to a document center document library. Process: I created an external content type using SPD --> created an external list in SharePoint --> created a site column lookup to the list --> added the column to a site content type --> use the site content type in the doclib.

The BCS connections were to a test dataset so i wanted to remove the test data and start clean with live data. For business reasons I couldn't delete the Document Library so I deleted; - the test data items - the content type from the library - all the associated list columns - the site content type - the site look up columns - the list on Sharepoint - the external content type on SPD

BUT the associated secondary columns still show in viewedit.aspx They must be associated to the list somehow but i don't know where or how. I can't see the column in Site Columns. I can't see the column associated to any site content type. They are not displaying in the library. I have used SharePoint Manager 2010 and I can see the columns in there but I can't delete them. **EDIT: They are showing as Read Only columns in SPD visible when clicking "Show Read Only" Columns. I can;t delete them because they are read only columns. I tried to use http://[site]/_layouts/fldedit.aspx?field=COLUMNNAME but because it's a lookup on a secondary column the column doesn't exist.

It's like I need to do a complete "refresh" of the document library. Is it possible to do this without deleting the library (this would be absolute last resort and isn't really an option as there are additional 3rd party configurations to this library). I can take all the data out to make it an empty shell and run a powershell command (if one exists) but the GUID of the library must remain.

Any help would be appreciated.

Thank you in advance Ruth

0

The solution I had to use was SharePoint Manager. Change the secondary columns to Read Only: False Delete the column directly in SharePoint Manager

I would stress that this was my solution and is not recommended by Microsoft

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.