I have a SP2010 list. I've given contribute permission level to a group of users but they don't see list items. When they open the see it says there's no item to show while it has plenty of items.

Any ideas may help

Thank you

4 Answers 4


Go to list settings- advanced settings and check Read Access. If it is set to read items that were created by the user then users will be able to see only theit own created items. You may need to set read all items option here.

  • Thank you Nadeem!. This is the case. I don't want to change this setting. But I want some users to see all items. What's the permission level I should give them? other than full control?
    – mohsenov
    Feb 24, 2014 at 12:37
  • To override this behaviour, you need to assign "Override List Behaviours". That possibly is not a good idea as that allows "Discard or check in a document which is checked out to another user, and change or override settings which allow users to read/edit only their own items" May 23, 2017 at 8:29

User groups are tricky. Make sure those users belong to the group. You can pick a specific user and "check permissions".


After you verify that the user has permissions to your list, via navigating to the permissions of your list, via list tab, list permissions, (e.g. your url will change to /_layouts/user.aspx?obj=%GUID to your List%),

once there make sure the group the user is a member of has permissions on the list, and if that is true then make sure that the items in the list inherit, if they don't you'll see a yellow bar indicating that some content has unique permissions.

After that check that the list is not scoped to a different audience, via list settings, audience targeting settings. If the box is not checked, then this is not the issue. If it is checked, the look at your list, there will be a target audiences column, check this that all three checkboxes are checked. then check the list items to see if they have been scoped, or just turn off audience scoping, unless you need it, if you need it you need to check each item

This post goes over targeted audiences on lists and libraries in detail and while it was first written for SP2007, it's still accurate in theory. http://office.microsoft.com/en-us/sharepoint-server-help/target-content-to-specific-audiences-HA010169053.aspx#BM2


It's an old topic, but I came across this when having the same issue. So for future people landing on this thread as well, there's what fixed 'my' issue.

The list has versioning enabled, and the version settings of the list had "Content Approval" enabled. Disabling this content approval setting, resolved the issue.

This setting specifies whether new items or changes to existing items should remain in a draft state until they have been approved, with no approval, the items are only visible to site owners, and the creator.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.