2

I am trying to create a workflow with sharepoint designer and the new sharepoint 2013 workflow option, however I got this: The option for the Sharepoint 2013 workflow platform is not available because the workflow service is not configured on the server

I have followed all steps here to install workflow manager, and workflow manager tools: http://levalencia.wordpress.com/2014/02/19/installing-sharepoint-2013-workflowmanager-and-workflowmanager-tools-in-an-offline-environment/

Then I configured it by following this:

http://www.spjeff.com/2013/03/27/configuring-workflow-manager-1-0-on-sharepoint-2013-screenshots/

All steps were correct, no errors.

I tried restarting the server as mentioned here: http://social.msdn.microsoft.com/Forums/sharepoint/en-US/2c260d6a-34e8-43b5-805c-1f1f00c88563/sharepoint-designer-2013-workflow-platform-is-not-available?forum=sharepointcustomization

Still issue is not solved.

In central admin, on manage service applications, it says: Workflow is Connected in IIS, the new website and app pools are all started.

One thing is that I made the register-spworflowservice with localhost instead of the servername, is that maybe the issue? please note I am not using SPD from inside the server, but from outside it.

Register-SPWorkflowService -SPSite http://myintranetdomain.com -workflowHostUri http://localhost:12291/ -AllowOauthHttp
  • Did you check it with SPD from inside the server? – Nadeem Yousuf Feb 27 '14 at 11:26
  • You can re-run the Register-SPWorkflowService cmdlet by adding the -Force attribute. It will overwrite the existing configuration. This time, you can put in the server name instead of localhost – Vardhaman Deshpande Feb 27 '14 at 15:30
  • I dont want to install SPD on the server. – Luis Valencia Feb 27 '14 at 19:37
  • Do I have to register the spworkflow service for each web application? – Luis Valencia Feb 27 '14 at 19:38
  • 1
    Also, are you sure that "localhost:12291" points to the workflow host service ? This answer has a lot of info on the subject: sharepoint.stackexchange.com/a/84211/10170 – Cameron Verhelst Mar 3 '14 at 7:26
6
+50

This guy mentions something about a feature that wasn't enabled because of use a blank Site Template, have you tried this ?

Enable-SPFeature -Identity WorkflowServiceStore –Url $yourUrl

Source: http://anujabhojani.blogspot.be/2013/06/the-option-for-sharepoint-2013-workflow.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.