I am trying install workflow manager using powershell.

I first downloaded the offline package using these steps: http://www.techtask.com/featured/workflow-manager-1-0-offline-installation-sharepoint-server-2013/

When I executed the install, the wizard shows me what it would do, but because we have many dev environments and they are all pointing to the same sql server database, then I needed to modify the script to change the DB Names, otherwise we would have conflicts when installing it another dev server.

The error I got is this:(its in the last step of the script)

Cannot validate argument on parameter 'SBClientConfiguration'. The Service Bus connection string

When I checked the value of the variable is this:

contains invalid property. ';RuntimePort=9354;ManagementPort=9355'

When I hardcooded that string into the variable I see this message:

Cannot validate argument on parameter 'SBClientConfiguration'. Configuration is missing required 
information. Make sure the property 'Endpoint'

This is my entire script

# To be run in Workflow Manager PowerShell console that has both Workflow Manager and Service Bus installed.

# Create new SB Farm
$SBCertificateAutoGenerationKey = ConvertTo-SecureString -AsPlainText  -Force  -String 'MyPassword' -Verbose;

New-SBFarm -SBFarmDBConnectionString 'Data Source=MYDBSERVER;Initial Catalog=MyPrefixSbManagementDB;Integrated Security=True;Encrypt=False' -InternalPortRangeStart 9000 -TcpPort 9354 -MessageBrokerPort 9356 -RunAsAccount 'CONTOSO\spfarm' -AdminGroup 'BUILTIN\Administrators' -GatewayDBConnectionString 'Data Source=MYDBSERVER;Initial Catalog=MyPrefixSbGatewayDatabase;Integrated Security=True;Encrypt=False' -CertificateAutoGenerationKey $SBCertificateAutoGenerationKey -MessageContainerDBConnectionString 'Data Source=MYDBSERVER;Initial Catalog=MyPrefixSBMessageContainer;Integrated Security=True;Encrypt=False' -Verbose;

# To be run in Workflow Manager PowerShell console that has both Workflow Manager and Service Bus installed.

# Create new WF Farm
$WFCertAutoGenerationKey = ConvertTo-SecureString -AsPlainText  -Force  -String 'MyPassword' -Verbose;

New-WFFarm -WFFarmDBConnectionString 'Data Source=MYDBSERVER;Initial Catalog=MyPrefixWFManagementDB;Integrated Security=True;Encrypt=False' -RunAsAccount 'CONTOSO\spfarm' -AdminGroup 'BUILTIN\Administrators' -HttpsPort 12290 -HttpPort 12291 -InstanceDBConnectionString 'Data Source=MYDBSERVER;Initial Catalog=MyPrefixWFInstanceManagementDB;Integrated Security=True;Encrypt=False' -ResourceDBConnectionString 'Data Source=MYDBSERVER;Initial Catalog=MyPrefixWFResourceManagementDB;Integrated Security=True;Encrypt=False' -CertificateAutoGenerationKey $WFCertAutoGenerationKey -Verbose;

# Add SB Host
$SBRunAsPassword = ConvertTo-SecureString -AsPlainText  -Force  -String 'MyPassword' -Verbose;

Add-SBHost -SBFarmDBConnectionString 'Data Source=MYDBSERVER;Initial Catalog=MyPrefixSbManagementDB;Integrated Security=True;Encrypt=False' -RunAsPassword $SBRunAsPassword -EnableFirewallRules $true -CertificateAutoGenerationKey $SBCertificateAutoGenerationKey -Verbose;

    # Create new SB Namespace
    New-SBNamespace -Name 'WorkflowDefaultNamespace' -AddressingScheme 'Path' -ManageUsers 'CONTOSO\spfarm','spfarm@CONTOSO' -Verbose;

    Start-Sleep -s 90
Catch [system.InvalidOperationException]

# Get SB Client Configuration
$SBClientConfiguration = Get-SBClientConfiguration -Namespaces 'WorkflowDefaultNamespace' -Verbose;

# Add WF Host
$WFRunAsPassword = ConvertTo-SecureString -AsPlainText  -Force  -String 'MyPassword' -Verbose;

Add-WFHost -WFFarmDBConnectionString 'Data Source=MYDBSERVER;Initial Catalog=MyPrefixWFManagementDB;Integrated Security=True;Encrypt=False' -RunAsPassword $WFRunAsPassword -EnableFirewallRules $true -SBClientConfiguration $SBClientConfiguration -EnableHttpPort  -CertificateAutoGenerationKey $WFCertAutoGenerationKey -Verbose;

1 Answer 1


Finally I solved it my self but not with the script

The thing is that when you install workflow manager with the offline web platform installer: see here

At the end of the process, the wizard will open.

There is a trick with this wizard, you cant edit the database names, and if you are like me where you share the sql instance with other development environments, then it doesnt make any sense to use those database names.

So, I tried the copy powershell commands option, and ran it. Then it failed with the error here.

However, I noticed then, there is a new tool installed the workflow configuration manager, and in there you have the option to create a new workflow farm, and update the DB settings

Please note this wizard is different to the wizard started at the end of the installation process, this wizard allows you more control

This post helped me a bit:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.