0

I made a search which is only searching on a specific list. The list has 30132 elements.

  • client.svc with the seach Webpart
  • _api/search/ with a specfic form

Both searches are returning a different number of totalRows when I search for "*"(client.svc returns 30132 and _api/search returns 29858).

Any idea why and how to solve it?

Thanks in advance

EDIT:

URL for the Ajax request:

https://www.intranet.i/site/_api/search/query?querytext='<searchTerm> AND ListId:<idOfTheList>'&rowlimit=100&trimduplicates=false
1

It can be the TrimDuplicates functionality!

Try adding &trimduplicates=false to the end of your _api/search string.

This functionality is meant to eliminate "duplicate" results, like documents with exactyl the same names and content.

More here: http://msdn.microsoft.com/en-us/library/office/jj163876.aspx (search for TrimDuplicates)

5
  • didnt't work, i get 30157 elements with trimduplicates=false
    – mbauer
    Feb 19 '14 at 14:08
  • Well closer ;) I guess EnablePhonetics and EnableNicknames and other properties like that can count.. Feb 19 '14 at 14:10
  • I tried both parameters but nothing changed
    – mbauer
    Feb 19 '14 at 14:37
  • 1
    Did you specify a result source? @RobertLindgren approach is correct, there is something missing (or added) that is causing the query to be different. Feb 21 '14 at 15:26
  • added the URL for the Ajax request in my question
    – mbauer
    Feb 24 '14 at 6:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.