0

I customized the fab 40 Absence Request template.

I added custom workflows with custom activities (spdactivities, http://spdactivities.codeplex.com/)

works beautifully in dev. Want to move to production.

save site as a template (with content so I can modift the workflows as needed)

get no errors for 'check workflow' but get this when I click Finish:

“(0, 10) The type or namespace name 'DP' could not be found (are you missing a using directive or an assembly reference?))”

My first instinct is to redeploy sdpactivities in production.

Anything else I should be looking at?

0

Make sure you have referenced dll in either GAC or bin folder. It seems you are missing any dll reference. Try to locate error in either EventViewer or SharePoint logs.

0

Some things to check

  • Installation in the GAC per ashish's post (must be installed in the GAC)
  • Ensure its been installed and the feature activated in your web application

Also check to see if your web.config (for the web app) has the following safecontrols registered

<SafeControl Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow.InfoPath" TypeName="*" Safe="True" />
<SafeControl Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow.Install" TypeName="*" Safe="True" />
<SafeControl Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Safe="True" />
  • THanks so much! ends up it was installed but not activated in production! thanks – user2314 Feb 4 '11 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy