2

enter image description here

I have a SiteCollection which has subsites and evertime i try to assign a workflow on a documentlevel or list level i get the error message **"**The workflow failed to start due to an internal error"****

I tried deleting the workflows and recreate then and i tried deactivating the OOB features at Site Collection Level and reactivated it but i still get the Error, has anybody come across similar issues.

Turned ON the Verbose Logging but there nothing specific in that Any suggestions.

  • did you found a solution? – Tiago Duarte Oct 10 '14 at 15:04
0

After bumping into this myself, here are my findings.

  • This happens apparently a lot in SharePoint 2007, but also in SharePoint 2010, for similar reasons
  • We can enable verbose logging for workflows (CA, Diagnostic Logging) and even enable workflow debugging. However, as the workflow never really starts, there will be little or none relevant log entries.
  • This is often related to caching or orphaned content types, or otherwise conflicts resolved by re-enabling features.

Now as for the actual (individual) solutions, in order of complexity:

  • Disable the "Workflows" feature and re-enable it [ref]
  • Restart owstimer and IIS (if it's an option) [ref] (comment)
  • Delete workflow assembly cache at C:\Users\profile name\AppData\Local\Microsoft\WebsiteCache [ref] [ref]
  • Remove orphaned content types [ref]
  • Stop workflow timer service [ref]
  • Using collaboration template instead of publishing [ref]
  • Delete and re-provision the list (good fix for development environments)
  • Disable, Uninstall and Re-enable all the workflow features [ref] (script below)

    $siteUrl = "http://sitecollectionurl.com"

    #deactivate and uninstall

    #OffWFCommon

    stsadm -o deactivatefeature -id C9C9515D-E4E2-4001-9050-74F980F93160 -url $siteUrl -force stsadm -o uninstallfeature -id C9C9515D-E4E2-4001-9050-74F980F93160 -force

    #ExpirationWorkflow

    stsadm -o deactivatefeature -id C85E5759-F323-4EFB-B548-443D2216EFB5 -url $siteUrl -force stsadm -o uninstallfeature -id C85E5759-F323-4EFB-B548-443D2216EFB5 -force

    #ReviewWorkflows

    stsadm -o deactivatefeature -id 02464C6A-9D07-4F30-BA04-E9035CF54392 -url $siteUrl -force stsadm -o uninstallfeature -id 02464C6A-9D07-4F30-BA04-E9035CF54392 -force

    #SignaturesWorkflow

    stsadm -o deactivatefeature -id 6C09612B-46AF-4B2F-8DFC-59185C962A29 -url $siteUrl -force stsadm -o uninstallfeature -id 6C09612B-46AF-4B2F-8DFC-59185C962A29 -force

    #translationWorkflow

    stsadm -o deactivatefeature -id C6561405-EA03-40A9-A57F-F25472942A22 -url $siteUrl -force stsadm -o uninstallfeature -id C6561405-EA03-40A9-A57F-F25472942A22 -force

    #install & activate

    #OffWFCommon

    stsadm -o installfeature -name offwfcommon -force stsadm -o activatefeature -id C9C9515D-E4E2-4001-9050-74F980F93160 -url $siteUrl -force

    #ExpirationWorkflow

    stsadm -o installfeature -name Expirationworkflow -force stsadm -o activatefeature -id C85E5759-F323-4EFB-B548-443D2216EFB5 -url $siteUrl -force

    #ReviewWorkflows

    stsadm -o installfeature -name ReviewWorkflows -force stsadm -o activatefeature -id 02464C6A-9D07-4F30-BA04-E9035CF54392 -url $siteUrl -force

    #SignaturesWorkflow

    stsadm -o installfeature -name SignaturesWorkflow -force stsadm -o activatefeature -id 6C09612B-46AF-4B2F-8DFC-59185C962A29 -url $siteUrl -force

    #TranslationWorkflow

    stsadm -o installfeature -name Translationworkflow -force stsadm -o activatefeature -id C6561405-EA03-40A9-A57F-F25472942A22 -url $siteUrl -force

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.