1

I tried creating an out of the box document library and added one taxonomy field. After I created a document and added a number of terms (about 50). If I try to edit the document in word it gives me an error because of the Document Information Panel when trying to save.

I think there is a limit with the number of characters in a field in the out of the box Document Information Panel. I am using SharePoint 2013 and Office 2013. Any ideas how to get around this issue?

  • what error is throwing, could you please share it. – Waqas Sarwar MVP Feb 13 '14 at 14:27
  • @WaqasSarwarMCSE The error I get in word is a pop-up saying: "This file cannot be saved because some properties are missing or invalid. Use the Document Information Panel to provide the correct values. Errors for required properties are marked with a red asterisks, and errors for invalid properties are marked with a red dashed border." But I get no dashed border and no asterisks. – Kurt Feb 13 '14 at 14:40
  • 1
    there are many post talking about the same issue...check this one: naimmurati.wordpress.com/2014/01/17/… social.msdn.microsoft.com/forums/sharepoint/en-US/… – Waqas Sarwar MVP Feb 13 '14 at 14:49
  • @WaqasSarwarMCSE Thanks for your reply. Even though the other problems get the same error I don't think its the same issue. I don't have any hidden fields apart from the ones out of the box. Moreover this issue only happens when I put alot of terms in the field. – Kurt Feb 13 '14 at 15:06
1

DIP will not allow more then 256 characters for a field if the field has the default False value for UnlimitedLengthInDocumentLibrary. If you set UnlimitedLengthInDocumentLibrary to true then DIP should allow unlimited length.

Set UnlimitedLengthInDocumentLibrary to True and update the field.

You can do that with PowerShell.

$web = Get-SPWeb webUrl
$list = web.GetList($web.Url + "/DocumentLibrary")
$field = $list.Fields["YourMetadataFieldName"]
$field.UnlimitedLengthInDocumentLibrary = $true
$field.Update($true)
$web.Dispose()
  • Thanks for your suggestion. Unfortunately that still didn't work. I think that length is only for SharePoint not office as well. I also tried setting the property on the hidden taxonomy field as well. – Kurt Feb 14 '14 at 10:05
  • The limit is for SharePoint but Office checks that for DIP controls validation. Things to check: 1. Set all hidden fields of the library and its content types to Optional and try to save again. 2. Go to the content type's Setting -> DIP setting -> Create a new template. This just to check the properties of the fields in DIP for any Max length. 3. Try from another Office version. Last October they messed up some validations for 2010 but maybe for 2013 too. – Naim Murati Feb 14 '14 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.