0

I have a web part page which was working fine till yesterday. When I opened it today it is showing error. I checked logs but couldn't find any worthwhile information. Then I tried to go to web part maintenance page and even that one is giving error. In log file I see error:

Value does not fall within the expected range.  

How do I fix this?

0

why you say maintanance page do you mean Contents=1 at the end of the url to see all webparts on the page?

Looks like you have some code running i presume a custom webpart that is looking in an array possibly that doesnt fall within the give range of the array?

you must have an error either on event viewer and/or uls logs!

if you do still get the error at Contents=1 than its not a webpart but some other code running on the page itself to tied to the page that is effecting it as no webpart should be running in maintanance.

  • Yeah it shows error when I do contents=1. And the weird part is the bug vanished automatically and then came again after an hour. By the way the web part is very simple. I am just displaying a document library on which I have applied XSLT. – Frank Martin Feb 12 '14 at 10:32
  • ok, so you need to update your webpart removing the xslt for now and update sharepoint with the webpart. it will solve the error. You can than look at the xslt to see where its going wrong! could you update your question with the xslt? – Ali Jafer Feb 12 '14 at 10:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.