4

When trying to configure the App Url, I get this message:

The Subscription Settings service and corresponding application and proxy needs to be running in order to make changes to these settings

I have followed this page, which should address the issue:

Unfortunately, even if

SettingsServiceApp - Microsoft SharePoint Foundation Subscription Settings Service Application Started 

and

Microsoft SharePoint Foundation Subscription Settings Service Application Proxy

are both started, the problem remains.

Have you got any suggestions?

2
  • +1 Anyone was able to solve this?
    – Mzn
    Feb 23, 2014 at 5:31
  • For me the services showed as Started in Manage Service Applications, but when checking in Manage Services on Server it was Stopped. Starting and IISRESET (as suggested below) solved it. Nov 26, 2015 at 12:26

3 Answers 3

3

You need to start subscription service, which is must for installing apps in SharePoint environment.

If you didn't already created subscription service use ps to install one,

New-SPSubscriptionSettingsServiceApplication -ApplicationPool "SharePoint Web Services Default" -Name "Subscription Settings Service Application" -DatabaseName "SubscriptionSettingsDB" | New-SPSubscriptionSettingsServiceApplicationProxy

To be on safe side, try this ps script,

$subscriptionSettingsService = Get-SPServiceInstance | where {$_.TypeName -like “Microsoft SharePoint Foundation Subscription Settings Service”}

if($subscriptionSettingsService.Status -ne “Online”) {
Write-Host “Starting Subscription Settings Service”
Start-SPServiceInstance $subscriptionSettingsService | Out-Null
}
else{
Write-Host “Subscription Settings Service was already started”
}

while ($service.Status -ne “Online”) {
# delay 5 seconds then check to see if service has started sleep 5
$service = Get-SPServiceInstance | where {$_.TypeName -like “Microsoft SharePoint Foundation Subscription Settings Service”}
}

If it's truely running then try PS to add Appdomain and url,

Set-SPAppDomain “apps.com” –confirm:$false

Set-SPAppSiteSubscriptionName -Name “app” -Confirm:$false

Reference

2
  • The OP says the Subscription Settings Service Application is running. I don't understand how suggesting to run the application using PowerShell will make any difference... It's already running... I'm facing the same issue, thanks for any useful insights.
    – Mzn
    Feb 23, 2014 at 5:30
  • 1
    @Mzn sometimes UI says services are running but there is a chance that they are stuck, so using -force attribute start them again by forcing even if they are stuck, try an IIS reset or restart your server as most times, it solves issues with services being hanged or not working properly. Feb 23, 2014 at 11:29
1

if you are sure that Microsoft SharePoint Foundation Subscription Settings Service Application Proxy are both started you have to check application pools in the IIS for 2 pools:

  1. SecurityTokenServiceApplicationpool if it was started
  2. Subscription service application pool you can find it by the following:
  3. right click to all app pools that have GUID names one by one
  4. click View applications
  5. then check the physical path for every one if you find (Subscriptionsetting) start this application pool
1

Another thing you can try is:

Go to Manage Service On Server, search for the one labelled "Microsoft SharePoint Foundation Subscription Settings Service" and Stop/Restart it.

Then performa an IISReset and try again.

1
  • Just tested an it was it - just starting service didn't help but after IIS reset SP CA recognizes that all is OK.
    – Mikhail
    Apr 5, 2017 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.