0

We upgraded one of our sites to SharePoint 2013 (We used DocAve Migrator).Everything came across, but we have one strange issue:

When we check-in a page, the content drops off. The page is using a RichHTMLField set to PublisingPageContent. If you check-out the page, the content shows up again. If you view the page properties the content is also showing correctly in the display form.

This is the field we use on the page layout:

<PublishingWebControls:RichHtmlField FieldName="PublishingPageContent" runat="server"></PublishingWebControls:RichHtmlField> 

Viewing the source for the content block in the checked-in page, it just gives this empty div:

<div id="ctl00_PlaceHolderMain_ctl00__ControlWrapper_RichHtmlField" class="ms-rtestate-field" style="display:inline" aria-labelledby="ctl00_PlaceHolderMain_ctl00_label"></div>

Ps. I've already had a look at a similar question, but didn't get any solutions from there: RichHTMLField value is not rendered in page

1 Answer 1

0

Is the Publishing Page Content field outside of the PlaceholderMain? What I've found in SP2013 is that any Rich HTML Fields need to appear inside the PlaceholderMain otherwise things like Web Parts don't appear (it's to do with how SP2013 renders these fields and web parts differently).

It may help if it's possible. The other thread you mention implies the Publishing Page Content field may not be present in the library, so I'm assuming from your question that you've checked this and that it is part of the content type associated with your page layout.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.