I am using SharePoint 2007 (MOSS) and I have stumbled across a rather odd issue.

I have a list that has a Lookup column to another list, which works fine. However, when viewing the list and trying to sort or filter, the entries that show up when clicking on the column header are in a seemingly random order. They aren't listed alphabetically, they aren't listed in the order of their IDs. I can't seem to find why they would not just list themselves alphabetically like the other list columns. This makes it hard for users to filter because they have to look through all of the entries in order to find what they are filtering for. I should mention that this Lookup column allows multiple entries, so the sorting option is not available from this menu.

Does anyone know why this list column is behaving this way, and/or a way to revert it back to sorting its filter options alphabetically?

2 Answers 2


As you say, you can't sort by the lookup column because it allows multiple entries. So you're getting unexpected results when click on another column? I mean, say you have 12 columns, and one of them is your lookup column ... if you click on any of the other 11, the list doesn't sort?

Also: has the view been customized in Sharepoint Designer?

  • The issue lies in the fact that the entries in the dropdown menu to select filters (when you click on the column header), the entries listed to select for filtering are in a random order... once they are selected the list sorts and filters correctly, but the ordering of the items in that selection list is throwing me a bit, particularly since it is the only column to do so. I haven't changed the view in SPD.
    – user2290
    Jan 31, 2011 at 18:00

Well the answer was simple, if a bit restrictive... I just changed the column type back to not allowing multiple values and the sorting in the drop down box worked again... strange, but then so many SharePoint issues are.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.