I have a List with some data in it. I can see the data while in standard view however when I switch to Datasheet view I only see a blank datasheet (no headings or data, just the MS Access icon and the * symbol) I can use the Print with Excel option and the data will open in excel no problem. This issue is only happening on one computer, I can switch computers and see the datasheet as expected.

Is there a known setting that would prevent the data from being displayed by IE?

Solution: I was able to talk with the user on this issue. It turned out the user edited the page but never saved his changes, instead just clicked away leaving the page in a kind of editable state. This caused the datasheet to fail. Once I was able to discard his edits the page when back to displaying the data correctly.

  • I have the exact same issue, have you found any solutions yet? – user276138 Feb 13 '14 at 8:50
  • I'm not sure if we found the cause of the problem but we believe it may have stemmed from a user who was editing the page and never saved his edits then went and started trying to view data. Once the user rolled back the page edits everything started working fine again. – Woodsy Feb 18 '14 at 20:47

I use IE - 11. one of my colleague had similar issue. I found a solution for her by clicking the setting icon on top right , then "compatibility view setting ", then paste site url in the first box and then press "ADD" button.

This solution might work, if this is a IE compatibility issue. Cheers. please let me know, if it worked

| improve this answer | |
  • Thanks for the suggestion. However, this did not solve the issue. The Compatibility view settings were in fact different on the two machines but changing them did not stop the problem from occurring – Woodsy Feb 7 '14 at 16:34

I am facing similiar issues with 2 client, and it appears that a recent upgrade of office disabled the ActiveX component for Access Web Database which you can search for on the MS office web site for more information on enabling or downloading a workaround.

| improve this answer | |

I am facing this issue within my company. I have yet to find the culprit that is actually breaking it, but just doing a simple repair on office resolves it.

| improve this answer | |

I had the same problem, it started when I unistalled some old version of SP Designer. I went to control panel, repaired my SP designer 2010 and it solved the issue. It might work reparing any MS office application or IE to make it install some files again.

| improve this answer | |
  • Thanks. I added the solution I found to the original post – Woodsy Apr 14 '15 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.