We have installed CU's for SharePoint and I've run psconfig to upgrade the environment. After running, the servers list as "No action required" and everything is well. Untill the next day... I checked CA again and the servers are once again listed with "Upgrade Available". Hmm, weird. Ok; ran the command again, same result. Next day: Upgrade Available again.

I checked with stsadm -o localupgradestatus and found out that one particular site collection (a root site collection) is listed because it requires an upgrade. But I don't know why its not being upgraded. Apparantly because of this single site collection, the entire farm is flagged as if it requires an update?

3 Answers 3

  1. I ran stsadm -o localupgradestatus to find out there were content database in need of upgrade.
  2. Then I ran Test-SPContentDatabase to find out what the problem with these DB's was. There were references to features which were already deleted on disk.
  3. So I removed those features using Powershell untill the Test-SPContentDatabase command did not return any more faults.
  4. After that I ran Upgrade-SPContentDatabase to upgrade the databases in question.
  5. Now stsadm -o localupgradestatus returned there was nothing left to upgrade.

This should clear the message that there is an upgrade available.

  • Could you please provide the powershell remove missing feature?
    – Mark L
    Jan 23, 2017 at 6:36
  • Sure, that's a combination between Disable-SPFeaure and Uninstall-SPFeature.
    – Jasper
    Jan 23, 2017 at 7:04
  • I run test-spcontentDB and found a missing feature. I am quite sure it is not necessary. This feature is not installed in farm and we do not have the install source. Can we disable/uninstall it from content DB so that it will not prompt when running test-spcontentdb?
    – Mark L
    Jan 24, 2017 at 3:05
  1. Restore this site collection on a separate test farm. Upgrade the content database and test farm matching it to your current farm. Take a backup again from the test farm and restore the site collection to your current farm. If your current farm is a production environment, till the time your site collection gets upgraded in the test farm, keep it on a read only state so that no new data is entered. Post restoration, you will perhaps need to run the check localupgrade status and it should show No action required.
  2. Verify the upgrade status of your content databases in your farm. Incase any upgrade is pending you need to the upgrade content database cmdlet.Run the check again and see the results.

I had the same issue and below activity helped me resolve it:

  1. Run the following in the SharePoint 2016 Management Shell to upgrade the compoments in the Central Administration database: Get-SPWebApplication | Get-SPContentDatabase | Upgrade-SPContentDatabase

  2. Run the SharePoint 2016 Products Configuration Wizard from the command line:
    PSConfig.exe -cmd upgrade -inplace b2b -wait -force -cmd applicationcontent -install -cmd installfeatures -cmd secureresources

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.