2

A brief overview:

I have a Sharepoint 2010 installation on Windows Server 2008 R2, with Office Web Apps installed. The Central Admin SQL Database in on the local server, but the SQL database that houses the Web Application's data is on a different server. As the title alludes, there is inconsistent behaviour when it comes to opening supported documents within Office Web Apps on the website as any user, including the administrative account.

  1. Excel spreadsheets(.xlsx) can be opened and edited normally. Users (assuming proper privileges) can view and edit these documents just fine. This has been working fine with no problems.
  2. Word documents (.docx) when clicked on to be viewed, load the ribbon with "File", "Open in Word", and "Edit in Browser" options. However, where the Word document data should be, it spins on "Loading..." then spits out the "Word Web App cannot open this document because the server is still processing the document. Try later" error with an error id. BUT when I click Edit in Browser, it opens up just fine and allows users to edit and save changes!
  3. Powerpoint presentations do not allow a user to view or edit. When trying to view, it gives "Either network connectivity has been lost or the server is too busy to service your request." When try to edit, it gives "PowerPoint Web App encountered an error. Please try again."

With all of the above tests, I made dummy documents that are empty to rule out file size or corrupt files being an issue. It's odd that spreadsheets have normal control, but the others don't(and that they have different behaviour. If it were permissions wouldn't they have the same problems?)

What I have tried and checked so far:

  • Sharepoint and OWA are installed on the server.

  • OWA is activated for the site collection.

  • I changed browser file handling from 'Strict' to 'Permissive', with no change. (described here as a potential solution: Office Web Apps - Word Cannot Read, But Can Edit)

  • Restarted the Powerpoint and Word Viewing services, with no change.

    -Checked the Powerpoint service pool; it was on "Web Services Default". Tried making a new pool using Network Service account under the Predefined account, but it didn't work. Even tried the other pools for kicks and no dice.

    -Checked the Manage Service Connections under Application Management->Manage Web Applications, and the services were checked. (as recommended on various blogs and other online sources)

After looking at this thread(Office web app error SharePoint 2010), it seems like my issue could be related to the last point SPDoctor mentioned.

How would I check if the service account doesn't have the right permissions to access the content database? What are all the accounts that need permissions on the SQL database(which, as I mentioned at the beginning, is on a different server entirely) and what permissions should they have?

What's interesting is that it doesn't affect Excel, partially affects Word documents, and fully affects Powerpoint. Should I run the Sharepoint products configuration wizard again? Or could reinstalling OWA solve my problem(while keeping all of my documents intact)?

Could I get a nudge in the right direction? What am I doing incorrectly?

  • I added a few more things I tried, but they still didn't help my problem. I think it's a permissions issue somehow, but I'm unsure where to start or what might be the culprit. What doesn't make sense is the differentiating permissions for file types. – Mr. Starburst Feb 14 '14 at 0:18
  • Anybody have any idea what's going awry? I'm willing to try just about anything at this point... – Mr. Starburst Apr 3 '14 at 19:05
1

Run this command, it should set your database permissions, just one part that you need to replace with your app pool name:

PS C:\Users\SPAdmin_svc_p> Get-SPWebApplication | % { $_.GrantAccessToProcessIdentity((Get-SPServiceApplicationPool -Ide
ntity "NAME OF APPLICATION POOL THAT OWA SERVICE APP USE" | select -expand ProcessAccountName)) }

You can also login to SQL management studio on your SQL server and check the database roles that are assigned to your service application pool account, it should have DBO on all content databases.

Like I said this should fix it, I have the exact same error as you, Excel works but Word only works in edit more, but it didn't fix it for me so I'm still working on it. None of the other solutions above from Alex, Kevin or Manish are at all relevant to the issue.

0

Had this problem to but found the solution. If it works and you have admin access to your computer then the problem for the rest is easy, add a directory called powerpointcache in your windows temp directory.

0

I had a very similar issue.

In my case it was solved by re-installing the OWA/WAC farm with the render cache on the C drive, which I had previously installed on the D drive. It didn't have to be in the default location but it didn't like being moved off C.

I did a test re-install and confirmed that it broke/fixed the issue. Details here:

TechNet Forums thread

0

I had the same problems with the Excel Services and found a solution for the office webapps for word and powerpoint also.

Follow the procedure below.

The problem was traced to SharePoint’s built-in URL redirection for various files types. Behind the scenes, SharePoint is attempting to redirect the Excel/Word/Powerpoint file to a common viewer component. We just needed to turn this redirection off.

Edit these 2 files serverfilespowerpoint.xml and serverfilesword.xml at the following location: Program Files/Common Files/Microsoft Shared/Web Server Extensions/14/TEMPLATE/XML

Comment out any lines with the file extension of "docx or doc" and "pptx or ppt"

For Example:

The file "serverfilesword.xml" should look like this

<?xml version="1.0" encoding="utf-8" ?>
<!-- Copyright (c) Microsoft Corporation. All rights reserved. -->
<ServerFiles>
    ***<!--<Mapping FileExtension="doc"  RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" />-->***
    <Mapping FileExtension="dot"  RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" />
    ***<!--<Mapping FileExtension="docx" RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate= "/_layouts/CreateNewDocument.aspx?id=|0" />-->***
    <Mapping FileExtension="docm" RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate= "/_layouts/CreateNewDocument.aspx?id=|0" />
    <Mapping FileExtension="dotx" RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate= "/_layouts/CreateNewDocument.aspx?id=|0" />
    <Mapping FileExtension="dotm" RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" />
    <Mapping FileExtension="odt" RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate= "/_layouts/CreateNewDocument.aspx?id=|0" />
</ServerFiles>

The same way for the "serverfilespowerpoint.xml" file edit the 2 lines in this file

--> -->

and save both the files.

Perform an IISReset and you will now be able to read and edit the files without any problems.

Cheers and Enjoy: "Do the things you fear and the fear will disappear"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.