I have a site that is strictly reports. I'd like to set up links for my users to the reports while denying them the ability to view the actual report site. Is this possible?

I've removed access from the site, set up the proper access on the list, and had the library stop inheriting permissions but I still get access denied when trying a link to a report. The report site states the users have limited access to specific reports but in reality they currently have no access.


You may limit a user to a specific library, but the navigation to that library must be absolute. He/She will not be able to browse to that site to get to the list or library they need to access. You will have to supply them with the direct link to the library/list. If the reports gather data from the respective sites that they do not have access to, it will throw an error, unless you are impersonating a user or using the secure store.

| improve this answer | |
  • That is exactly what I want. How do I accomplish this? – SandSnark Jan 27 '14 at 19:08
  • uninherit the list from the site, through the List Settings -> Permissions on this list -> Uninherit. Then add that person to the permissions. Give the URL to the list to the person, and they should be able to see the list. – Mike Jan 27 '14 at 19:13
  • Unfortunately, that is exactly what I did but it does not work. The library does not inherit permissions, the users are setup with 'Read' permission on the library (but not the site) and I'm using the SharePoint 'Email a link' as the URL. – SandSnark Jan 27 '14 at 19:28
  • 1
    Use Fiddler to see which content they are getting denied at. It may be the masterpage, CSS files, or other supporting content that the masterpage is referencing that they do not have access to, or that is not checked in. Please check to see if you have Site Assets/Style Library or other content that the masterpage references. – Mike Jan 27 '14 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.