I 'm trying to open a document lib with Open with Explorer but when it loads its all blank. I'm sure i do have access to the doc lib.

Any ideas and thanks in advance.

  • Do you have lot's of document in that library and how many you have? Commented Jan 24, 2014 at 8:44

3 Answers 3


It is not recommended to exceed 2,000 items in a list level, and to use Explorer view to view large document libraries. Instead, you may choose to use All Document view, when open a SharePoint document library in Explorer view, placing the pointer over any of the enumerated files requests metadata for all of the files in the folder that you are browsing.

As in this scenario, it may be the large number of the documents that make the Explorer View not working, here is an article about “Tune Web Server performance(Office SharePoint Server)”, there are some points we need to pay attention to in “Train end-users to work with large files”, for more information, please refer to: http://technet.microsoft.com/en-us/library/cc298550(office.12).aspx


Check if the files are checked out to some other account or not, to view the files in explorer view, files should be checked in.

have a look at the below links too,

Document Library in Explorer view "This folder is empty"

Explorer View 'This folder is empty'

All about “Explorer view” in SharePoint

  • Thank you so much! I couldn't figure out why the user who had permissions only on the document library and not on the site couldn't access the files through Explorer view. It was because the site collection feature, "Limited-access user permission lockdown mode" was enabled. Once I disabled the feature the user could access the files through Explorer view!
    – ajshultz1
    Commented May 23, 2017 at 16:32

We had the very same issue in case of a user, who had permissions only on the document library, but not on the web site. Solution was to inactivate the "Limited-access user permission lockdown mode" site collection feature.

Another day we had it either, caused by a corrupted .pdf file in the folder. After the corrupted file was deleted, Windows Explorer displayed the remaining files. The same reason is described by pagemichael. Seems to be a client-side issue: I've checked the response sent by the server using Fiddler, and the server sent the list of the files correctly to the WebDAV client (Windows Explorer).


Also one of the reasons is: The specified item or folder name is too long. The URL path for ALL items and folders must be 260 characters or less (AND no more then 128 characters for ANY single item or folder name in the URL).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.