12

I have a strange issue where no office files will open within SharePoint 2013.

When I click on any word, excel, powerpoint file I get "the webpage cannot be displayed" and there is some text added in front of the original typed address.

ms-powerpoint:ofv|u|http://www.examplesite.com/Shared%20Documents/Presentation1.pptx

ms-word:ofv|u|http://www.examplesite.com/Shared%20Documents/Test.docx

ms-excel:ofv|u|http://www.examplesite.com/Shared%20Documents/songs.xls

Strangest thing of all is that Access files open with no trouble.

Any ideas?

  • 1
    I think you should try to go through the questions you have asked and spread some upvotes and / or accept answers to give some credit to all the people that have helped you out on this site. You have asked quite a few questions, gotten some good answers but never accepted a single one ;) – Robert Lindgren Jan 28 '14 at 19:15
  • Which Office applications do you have installed and are they of different versions? Office 2010 but Access 2013 or something like that? – Robert Kaucher Feb 20 '14 at 17:17
7

I had a similar issue; the links in my doc library no longer opened up the document. The problem was having Office 2010 and part of Office 2013 installed (in my case, SharePoint Designer 2013 and SkyDrive Pro).

Installing Service Pack 2 for Office 2010 fixed the issue.

32-bit download http://www.microsoft.com/en-us/download/details.aspx?id=39667

64-bit download http://www.microsoft.com/en-us/download/details.aspx?id=39647

  • We had the same issue and Office 2010 Service Pack 2 fixed it for us as well. – user31736 Jul 21 '14 at 16:29
5

I came across many such situations and the most common culprit of this issue is installing SharePoint Designer 2013 on top of Office 2010.

Looks like some of the Office 2010 components conflict with Office 2013.

Some options to resolve this issue:- 1. Remove SharePoint Designer 2013 (or any other Office 2013 component). 2. If you decide to keep SharePoint designer, please do install SharePoint Designer Hotfix 3. Make sure to remove SharePoint.OpenDocuments.5 key from your registry.

Right Click on HKEY_CLASSES_ROOT --> Select Find Search for SharePoint.OpenDocument.5 and remove it

Hope this helps

Additionnaly you may need to edit SharePoint.OpenDocuments->CurVer and replace SharePoint.OpenDocument.5 by SharePoint.OpenDocument.4 - This will restore open document dialog box in SharePoint when you click on document (with Read Only and Edit Options)

  • This will definitely solve your issue :) – Sudhir Kesharwani Jan 22 '14 at 20:25
  • this solution is applicable to office 2007 also; i have office 2007 and spd 2013, run into the same issue and the above changes to the registry fixed the problem. – Paolo Jun 25 '15 at 7:39
  • After long hours of investigations I have found this answer which solved my issue. We had removed the SharePoint.OpenDocuments.5 key a few years ago. Since we switched to Office 2016, documents from a SharePoint 2013 library were always opened in the corresponding web app instead of the client application, although we had all settings defined to open documents in the client application. Your hint regarding the SharePoint.OpenDocuments => CurVer solved this issue for us. Thank you! – stal2401 Nov 30 '18 at 9:38
2

I'll take a wild guess that you have Office 2010 installed and then have installed some application from Office 2013?

If so, check out this link:

http://blogs.technet.com/b/raymond_ris/archive/2013/04/04/cannot-open-or-create-word-documents-in-sharepoint-2013-with-office-2010-and-project-2013.aspx

Basically you must remove the feature "Microsoft SharePoint Foundation Support" from the Office 2013 products installation.

The run a repair of your Office 2010 installation

0

We were experencing a similar issue primarily with Excel.

At the Site Collection level under Site CollectioN Faetures, we enabled "Open in Client Application". By default the libraries were set to "Use Server Default (Open in Client Application). Which always selected browser.

Not the answer you're looking for? Browse other questions tagged or ask your own question.