0

We are using a tool (DocAve) to migrate our SP 2007 instance to 2013. We installed and configured workflow (WFM) manager on the 2013 server so we could make use of the new framework. We have done a test migration and everything came over well with one exception. When I try to manually start a 2007 workflow (designed in SharePoint designer) from a list item, I get an error when the WF page comes up. This is true for every 2007 workflow that got migrated. I determined the problem was WFM, so I completely uninstalled it and it worked, I was able to get to the WF page.

My "theory" is that since the migrated 2007 workflows are stored directly in SP and not in WFM, SP can’t find the information about them in WFM database so it errors out. Here are the errors I get in ULS:

System.Net.WebException: Unable to connect to the remote server

System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it

Application error when access /_layouts/15/Workflow.aspx, Error=No connection could be made because the target machine actively refused it

My question is how can I get the SP 2007 definitions into WFM? There could also have been something wrong with my WFM configuration. All I know is that it worked when I uninstalled it.

Edit: so I think this article might have answered part of my question:

http://www.codemag.com/Article/1301021

It appears you can't get 2007/2010 workflows in WFM, but you can call 2010 WFs from a 2013 WF. Not sure about 2007 WFs. Guess I have to test it. Even if it did work, it would require creating a 2013 work flow for every 2007 workflow.

The second part of the question is why I get the error when accessing the workflow page. Why would SP try to locate the 2007 WF in WFM (if that is what is happening)? Is this true with 2010 WFs too?

0

I just discovered the workflow manager backend service keeps crashing, which is why I could not access the workflow page. There appears to be four configuration settings missing from the WorkflowServiceConfig table in the database WFResourceManagementDB:

  • WorkflowServiceScopeSnapshotProcessBatchSize
  • WorkflowServiceScopeSnapshotProcessLoopInterval
  • WorkflowServiceSuspendedInstanceRetentionDuration
  • WorkflowServiceMaxInstanceCompressedSizeKB

based on this post: Install / Config / VS Debug? Error

Once I added these to the database and gave them a value (based on similar entries in the table), the problem was resolved. The question is why did the install/config not populate these and what are their actual values supposed to be? I uninstalled/reinstalled multiple times to no avail.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.