0

I have migrated our SharePoint development environment from 2010 to 2013. While migrating we had multiple problems - especially with our custom template, we had to make an additional step while deploying the package.

Finally, it's working on our development environment, but, when trying to do the same thing with the new package on the production environment, it's really unstable. For example when trying to change the look of the site, it crashes.

Here's the log:

Log Name:      Application
Source:        appSource
Date:          1/22/2014 12:52:13 PM
Event ID:      0
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      myserver.local
Description:
User Login : username - SPSiteId : c318bc64e71f4308bc40d02ea51b6894 - Url : http://myserver.local/silog ID du composant : SimulZoneVisualWebPartUserControl - Method Name : CreateChildControls - Message : message additionnel : Error on loading exception : Thread was being aborted. - Stack Trace :   at System.Threading.Thread.AbortInternal()
   at System.Threading.Thread.Abort(Object stateInfo)
   at System.Web.HttpResponse.AbortCurrentThread()
   at Project.WebParts.SimulZoneVisualWebPart.SimulZoneVisualWebPartUserControl.OnReinitDataClick(Object sender, EventArgs e)
   at Project.WebParts.SimulZoneVisualWebPart.SimulZoneVisualWebPartUserControl.UpdateLocalParameters()
   at Project.WebParts.SimulZoneVisualWebPart.SimulZoneVisualWebPartUserControl.CreateChildControls()
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="SiLog" />
    <EventID Qualifiers="0">0</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-01-22T11:52:13.000000000Z" />
    <EventRecordID>1232808</EventRecordID>
    <Channel>Application</Channel>
    <Computer>myserver.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>User Login : username - SPSiteId : c318bc64e71f4308bc40d02ea51b6894 - Url : http://myserver.local/silog ID du composant : SimulZoneVisualWebPartUserControl - Method Name : CreateChildControls - Message : message additionnel : Error on loading exception : Thread was being aborted. - Stack Trace :   at System.Threading.Thread.AbortInternal()
   at System.Threading.Thread.Abort(Object stateInfo)
   at System.Web.HttpResponse.AbortCurrentThread()
   at Project.WebParts.SimulZoneVisualWebPart.SimulZoneVisualWebPartUserControl.OnReinitDataClick(Object sender, EventArgs e)
   at Project.WebParts.SimulZoneVisualWebPart.SimulZoneVisualWebPartUserControl.UpdateLocalParameters()
   at Project.WebParts.SimulZoneVisualWebPart.SimulZoneVisualWebPartUserControl.CreateChildControls()</Data>
  </EventData>
</Event>

I don't really know from where this comes from.

Thanks in advance.

  • what authentication your web app using...Claim or classic....did you convert it to claims. – Waqas Sarwar MVP Jan 22 '14 at 13:39
  • claim authentication. But I was thinking that this does not come from the custom template, web parts ? I do not have to migrate them to work under SP 2013 ? – Ali Jan 22 '14 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.