1

In my sub-site, when I click on Site Actions, I only have three options:

  1. Create
  2. Edit page
  3. Site settings

In my main site, I have many more options when clicking Site Actions, including Create Page which is the first option.

  • Seems to be permissions issue.. Can you make sure for the subsite you have Full Control ? – Arsalan Adam Khatri Jan 20 '14 at 9:35
4

It sounds like you need to activate the publishing feature down at the sub site level. This will create the Site Pages library for you.

To do so go to Site Actions > Site Settings > Manage Site Features (under the Site Actions section) > Active "SharePoint Server Publishing". Note that you should do this down at the sub site level where the Create Page option is missing.

1

I've done a bit of research on this, as I wanted to better understand the behavior of the Site Actions menu. By inspecting the code with reflector, I found this line of code inside Microsoft.SharePoint.WebControls.SiteActions:

MenuItemTemplate menuItem2 = this.GetMenuItem("MenuItem_CreatePage");
if (menuItem2 != null && (web == null || web.UIVersion < 4 || (web.WebTemplateId != 1 || (int) web.Configuration == 1)))
    menuItem2.Visible = false;

The relevant part here is the last OR condition, which means: hide the menu if the current site web template is != 1 (so it's not a Team Site) OR, if it is indeed a team site, hide it when the applied configuration is 1 (the blank team site).

So, the menu item is hidden if your site is not a team site. When you activate the publishing feature -as suggested in spstu's answer- a SiteActionMenuCustomization feature is called and I think this is responsible for getting the New Page menu item to show up.

I'd like to get comments on my speculation from someone more expert than me.

0

looks like your user account that your using doesnt have full control over the subsite but you do on site collection.

goto your subsite -> click site actions -> site settings -> click on site permissions ->

if you can see your user account on the list, click on it and change the permission to full control.

if its not than you need to add the user account and give full control!

also like to note what site did you make (sub site??)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.