4

I have various web applications running in our SharePoint2010 farm, one of them being the MySites web application.

For people connected externally (not within our network, which automatically authenticates), when a people search is performed and a profile picture attempts to load, the user receives authentication prompts for mysite. I would like to find a way to have this stop occuring once they have authenticated themselves to the main site that has the enterprise search.

Internally, everything works as it should (no authentication prompts). We are using Windows Authentication with Kerberos. The site is accessed externally via HTTPS and an external IP.

How can we stop these authentication prompts from occurring from mysites?

3

If you maintain MySites in another web application you need to know that pictures are stored in a library User photos in My sites Host, reason for which everywhere where User picture needs to appear (e.g. comments, notes) it makes a separate request to the other Web Application.

  1. if the site loading pictures is itself anonymous, you would need to enable same anonymous access for reading on the My Site host (http://support.sherweb.com/Faqs/Show/how-to-enable-anonymous-access-to-a-sharepoint-site-sharepoint-2013)
  2. if the site requires authentication, you need to give read permissions to all authenticated users to the MySite Host or otherwise it won't work irrelevant to authentication protocol
4
  • Thanks for the reply! The site does require authentication, and it does have "all authenticated users" with view access to the Profile Photos image library. The problem is that site A is loading profile images from Site B (mysite) and the user hasn't authenticated to Site B yet, hence the authentication prompt. I would like to find a way to somehow have pass-through authentication for SiteB so that if a user authenticates to SiteA it automatically authenticates to SiteB. Is that possible?
    – Kolten
    Jan 17 '14 at 21:23
  • You mentioned that you have Kerberos - right? if it does require to authenticate it also means is doing fallback to NTLM. You need to check whether your Kerberos is actually working (use this blog.michelbarneveld.nl/michel/archive/2009/12/05/…) Jan 17 '14 at 21:27
  • It is working - INTERNALLY. EXTERNALLY there is no option to use NTLM or Kerberos. External access is the only place where multiple authentication prompts occur - internally, everything works flawlessly.
    – Kolten
    Jan 17 '14 at 21:55
  • The option to configure NTLM/Kerberos is in the Web application. Did you disabled loopback or configured backhostnames? Jan 17 '14 at 23:22
0

I have workaround for this... hope it may hep you

1) Create a separate list. The list data is filled with the user details with a timer job.

2) Use the above created list to search for the user photos.

Note: If you ignore duplication of data in separate list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.