2

I got a custom document library, deployed from Visual Studio 2012 which contains the Enterprise Metadata Field.

While saving an item in SharePoint2013, I get the following error:

The SPListItem being updated was not retrieved with all taxonomy fields.

Managed Metadata Service is configured, up and running, ressource throttling is configured as well. Does this have something to do with the Content Type Hub which can be connected to the Metadata Service?

EDIT: Here is the list definition:

    <Elements xmlns="http://schemas.microsoft.com/sharepoint/">
  <!-- Parent ContentType: Document (0x0101) -->
  <ContentType ID="0x0101003CCD44FE45204BDCB43383EBE597861D" Name="Weisung" Group="My Content Types" Description="My Weisung" Inherits="TRUE" Version="0">
    <FieldRefs>
      <FieldRef ID="{da49ac5a-242a-44fb-b39b-fce1d934bf54}" DisplayName="Weisungs-Verantwortliche Person" Required="TRUE" Name="WeisungsVerantwortlichePerson" />
      <FieldRef ID="{67df98f4-9dec-48ff-a553-29bece9c5bf4}" DisplayName="$Resources:core,Attachments;" Name="Attachments" />
      <FieldRef ID="{3ef926f3-80d1-437a-9e5f-6cc0a87c8513}" DisplayName="Gültigkeit Bis" Required="TRUE" Name="GueltigkeitBis" />
      <FieldRef ID="{bf54d65c-3d8d-4491-bed6-a0211565f9b8}" DisplayName="Themen" Required="FALSE" Name="Themen" />
      <FieldRef ID="{845976B1-7BCA-4A90-A87A-9208D9D53356}" DisplayName="Segment" Required="TRUE" Name="Segment" />
      <FieldRef ID="{1390a86a-23da-45f0-8efe-ef36edadfb39}" DisplayName="TaxKeywordTaxHTField" Required="FALSE" Hidden="TRUE" Name="TaxKeywordTaxHTField" />
      <FieldRef ID="{23f27201-bee3-471e-b2e7-b64fd8b7ca38}" DisplayName="$Resources:osrvcore,field_KeywordsFieldName" Required="FALSE" Description="$Resources:osrvcore,field_KeywordsFieldDesc" Hidden="FALSE" Name="TaxKeyword" Sealed="TRUE" Sortable="FALSE" />
      <FieldRef ID="{f3b0adf9-c1a2-4b02-920d-943fba4b3611}" DisplayName="Taxonomy Catch All Column" Required="FALSE" Hidden="TRUE" Name="TaxCatchAll" Sealed="TRUE" Sortable="FALSE" />
    </FieldRefs>
  </ContentType>
</Elements>
  • could you add some code – Remko Jan 18 '14 at 8:42
1

It's not enough to add TaxKeyword to your content type/list, you have to add TaxKeywordTaxHTField as well. This one is a hidden field but neccessary to get the keyword-field working.

But it doesn't stay persistent within the item. After saving, it's gone again.

Except when done the following: http://social.msdn.microsoft.com/Forums/de-DE/678f9297-0509-4dcf-8be5-1931df4325a3/enterprise-keywords-are-not-saved?forum=sharepointgeneralprevious. But I have to integrate this in my VS2012-Solution, so everytime I restart debugging, it's gone again. Any ideas how to make the keywords persistent?

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.