I created a document library (no specific source templates needed or wanted). The purpose of library is simply to provide a central location for frontline staff to access information (processes, Q&As, letters, etc.) to do their jobs.

I have several Customer Letters (.dotx -Word Template files) saved as items in the library. My problem is that the letters are opening in read-only with prompt for users to checkout template file (overwrite template!).

This prevents several users from accessing letters at same time AND compromises the integrity of the templates.

I do not want the resulting letters (new documents) created by staff to be saved to, or linked to, the SharePoint library. They will be printed for mailing to customer and also may be electronically sent to a separate application for archiving purposes.

What I need is for users to access the letters (either directly from library or a web part) as an entirely NEW document (i.e. 'Document1') based on whichever doc template was selected.

I have not found a solution as most other enquiries accept that the library will be dedicated to saving documents based on a specific template in SharePoint. I need Word to be my template manager, not SharePoint.

Is there a way to NOT open template file, but create New based on .dotx?

5 Answers 5


One of the core functions of sharepoint's document libraries is just that!

Store the Templates in the Forms folder within the library, allow multiple content types, and associate the templates to various content types.

Here's some links to get you started. Welcome to sharepoint!




Had the same Problem, found this Solution: http://wowsomuch.com/sharepoint/opening-office-templates-dotx-sharepoint-document-library/

This solution overrides the html link to the documents using some jQuery to use the createNewDocumentWithProgID function (from the core.js library) to get the required behaviour.

  • 1
    It would be good if you elaborate your answer with some content and explanation Like how and what you did to solve the problem. One liner answers do not help and there is a rare chance to get an upvote or accepted.
    – Asad Refai
    Commented Jun 10, 2015 at 15:09

The problem with associating templates with content types is the SharePoint wants to create the new document in the SharePoint library, a result requested not to happen.

In the Library Tabs bar at the top of the SharePoint Library, go into the Library Tools -> Library tab. Then in the Connect & Export section of that tab is Open With Explorer button (icon is a yellow folder and a blue monitor). That will open a Windows Explorer window in which you will see the template files. Go up one folder in Windows Explorer (Backspace key). There you will see the folder icon for your Library. Right click the folder and choose Copy. Right click your desktop and choose Paste Shortcut. Now you have a desktop icon that gets you straight to the library with the templates in a mode where double clicking the template icon:

  1. Opens a new document based on the template, and
  2. Keeps the new document from being associated with the library.

I believe that meets the requirements of the question.

(I am using SharePoint 2010.)


I tried the aforementioned solution mentioned at wowsomuch by saving the script as a file and linking it to a Content Editor web part on the page with the template links and found the following.

It only works for me, sort of, in 2 of 3 scenarios:

  1. manual link : works *
  2. library web part : works *
  3. content query web part: does not work

    • a window is displayed with the following… however Word does open it up as a new document

The document could not be created. The required application may not be installed properly, or the template for this document library cannot be opened.

Please try the following: 1. Checek the General Settings for this document library for the name of the template, and install the application necessary for opening the template. If the application was set to install on first use, run the application and then try creating a new document again.

  1. If you have permissions to modify this doucment library, go to General Settings for the library and configure a new template.

Here's what worked for me - Save all templates (Word, etc) in doc library in SP - In doc library, click "Open in Explorer" - In Explorer, right click template and select New. - Word (or Excel or ...) opens Document 1 using template

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.