Sharepoint 2013, I add a discussion board via insert Web Part (also tried as App Part). I want to set notification on a topic by clicking "Alert me". On the next screen I adjust the settings and hit OK and get this error message:

Sorry, something went wrong

An unexpected error has occurred.

Web Parts Maintenance Page: If you have permission, you can use this page to temporarily close Web Parts or remove personal settings. For more information, contact your site administrator.

However, an email is sent telling me that the notification has been set successfully; indeed it worked since I get notifications as per my settings.

I could work around it by hacking the message away with a JavaScript/Ajax script but I do like to know what's going on.

Any idea what causes this behaviour?

---- edit to answer Zafua's question ----

If I construct the URL as you suggest:


I get to the same page as when clicking on the link behind the error message (Web Parts Maintenance Page); is this correct? If yes I get the following screen:

Web Parts Maintenance Page

I guess if I delete the item the discussion board will be deleted as well.

2 Answers 2


It must be caused by wepbarts in the page. Please check are there any incorrect webpart.

You can check with ?contents=1 querystring. Like this:


If it existed incorrect webpart, just delete it.

  • Hi Zafua, I edited my question accordingly. Jan 16, 2014 at 8:41
  • No discussion board wont deleted. Only view will deleted. Discussion board is also Sharepoint list. And you cant delete a list with this way. If it doesnt help, please give extra detailed log like ULS. Further info at here and ULS Viewer
    – Zafua
    Jan 16, 2014 at 20:43
  • I deleted the item, the board is still there but if I want to view a post I get an empty page. Creating a new post results in the following error message: One or more field types are not installed properly. Go to the list settings page to delete these fields. Which is kind of explainable since I deleted the view. How can I recreate it? Jan 17, 2014 at 10:12

Settings -> Edit Page -> Edit web part -> Ajax Options -> Mark 'Enable Asynchronous Load' & 'Enable Asynchronous Update' ->click OK on web part options -> Page -> Stop editing

  • 1
    Can you please add more details to your answer (like instructions for how to enable async updates on the webpart). Right now the answer is not as helpful as it could be Aug 5, 2014 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.