5

I'm having problems to make my site creation work.

I followed the guide at this blog, everything is setup as what described. If I go to personal site, i.e. http://my_host.com:80/my/myinc_sp_test, I can see the new site link. When click it, it pops this error shown in screen shot. What I wanted to do is create the site collect at: http://my_host.com:80/my/testtest

However, if I go to this page's site content, create a subsite, it works fine. One subsite url is shown in screen shot with yellow circle. The created subsite is at: http://my_host.com:80/my/myinc_sp_test/testtest

myinc is the domain name, it is the prefix for personal site.

anyone knows something about this error? or any clue how I can fix this?

BTW, if I go to http://my_host.com:80/_layouts/15/scsignup.aspx , I can see the create team site page, fill in info, click the create button. It shows error with no much other info.

Thanks

enter image description here

*** BTW, I just know 1 thing: this site collection (my site host) was migrated from another server. Here is how it was done: create web app on this new server, then export content database from the old server, then attach to the new server. after this, everything else works fine. Could it because of this?

UPDATE: This is odd. I removed all permissions, add permissions, disable self-service, then enable self-service. Then try to create the site (it is site collection, not subsite under personal site). same error messages. The setting I use is in below screen shot: enter image description here

So, I played the settings, and I accidentally changed one setting: I removed the "my/[%userid%]" in the above screen (so it is blank). When I try to create site again, it shows this error:

enter image description here

I'm using a domain user account. So I think if I use a farm admin account, it should be ok? It turns out YES. It works for farm admin! So, it is because of permission! But what permission? So I removed all user permissions again, and add permissions again (just like i did before), weird thing happened: now, it works for domain user! but only for root domain http://my_host.com/ . I played more and found a more weird thing. See the 2nd screen shot, I choose the "Prompt users to create a site collection under any managed path" (red circle), when I click add new site, it works:

enter image description here

See the site collection url, http://my_host.com/my/my_test_site_collection ? I do not understand what the difference between this and the choice in the 1st screenshot (if I give it a name my_test_site_collection).

Anyone understand this? to me, I'm ok with it since I can use it (the last screen), but would like to know why it shows error in the first screen.

  • are you shareing the same web App for the MySite host and your other team site? its highly recommended use a separate web app for MySite... – Waqas Sarwar MVP Jan 15 '14 at 13:57
  • also make sure...self site creation enabled and users having the permission to create mySite. – Waqas Sarwar MVP Jan 15 '14 at 13:59
  • no, the web app is for the MySite host only. Personal site, and subsite under personal site is ok, but can't create MySite. somewhere the permission for site collection creation failed (I think), not sure where/how to check. – urlreader Jan 15 '14 at 16:14
  • yes, enabled, and have permission. Personal sites and subsites creation works fine. User Site Collection creation failed. – urlreader Jan 15 '14 at 16:15
0

For me lookalike its permission issue. did you grant every user to create team sites.

Perform these additional steps to configure permissions for users to create team sites from their My Sites to use site feeds.

In the Policy group, click Permission Policy.

On Manage Permission Policy Levels dialog box, click Add Permission Policy Level.
Type a name for the permission policy.

Under Permissions, in Site Permissions, select the Grant option for Create Subsites - Create subsites such as team sites, Meeting Workspace sites, and Document Workspace sites.

Click Save.

In the Policy group, click User Policy.

On Policy for Web Application dialog box, click Add Users.

On Add Users, in Zones select (All Zones), then click Next.

In Choose Users, enter the user names of the users that you want to create team sites from their My Site to use site feeds. If all users can create team sites from their My Site to use site feeds, click the Browse icon. In Select People and Groups, click All Users, then click Everyone. Click Add, and then click OK.

In the Choose Permissions section, select the name of the Permission Policy created previously.

Click Finish, and then click OK.

here is he link

  • I believe it is permission too. Yes, I did all these steps. Actually, user can create subsite under personal site, i.e. my_host.com/my/myinc_myid/my_new_subsite . The error pops when click New Site link on personal site try to create my_host.com/my/my_new_site . I think somewhere the user should have permission to create Site Collection under my_host.com/my . Although it is set already, but it seems not working as designed. I'll disable self-service creation, then enable it. Do not have access to system now, will report back tonight. thanks – urlreader Jan 15 '14 at 18:27
  • i would check the ULS logs for more in depth error details...meanwhile check the step 11 to 17 from below link an make sure that exist for mysite webapplication.sharepoint2013help.blogspot.com/2013/06/… – Waqas Sarwar MVP Jan 15 '14 at 18:52
  • thanks. however, every step was followed exactly before. no success. I'll check ULS tonight. – urlreader Jan 15 '14 at 21:18
  • I just know 1 thing: this site collection (my site host) was migrated from another server. Here is how it was done: create web app on this new server, then export content database from the old server, then attach to the new server. after this, everything else works fine. Could it because of this? – urlreader Jan 15 '14 at 22:39
  • Another server means another faem? And after creation new web app...did you update the mysite host info if it is changed – Waqas Sarwar MVP Jan 16 '14 at 1:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.