2

I'm creating a sitepage in designer and need to add a webpart using the existing custom list. But, I'm not able to get any options such as "Data View" in the insert tab. Its seems to be greyed out. I have placed the cursor in the zonetemplate and no luck yet. What may be the cause for this ? I'm the admin user for this site too.

EDIT

This was working fine before. There was some error occurred in one of the custom lists and I have removed it from the server. I have enabled/disabled some features (Publishing,Wiki etc) while doing this. Don't know whether this will affect this greying out somehow. Any idea on this?

  • Any hints about this? – Anish V Jan 15 '14 at 4:07
8

I've experienced the very same problem (Insert Data View was disabled in SP Designer 2013). The cause is the oslo master page and a bug in SP Designer 2013.

Solution: In SP designer go to Master Pages and set SEATTLE master page as the default one. Then create a new web part page, give it a name and start editing in advanced mode.

In the top ribbon go to edit, parse HTML, save the page. Now the option INSERT Data View should work (these steps worked for me anyway). After you finish, you can change back the master page to OSLO template.

Good Luck

| improve this answer | |
6

I have got a solution for the problem and thought of sharing it here, so that someone may get benefit it later. The issue was related to the permission. But, I have given the full permission to the user which also didn't worked. I don't know how it worked, but the trick is as given below.

I have checked out one file and checked back in. After this, I'm getting all the options in the Insert tab !! Best of luck!!!

| improve this answer | |
2

When you insert the data source, SharePoint:SPDataSource ...must be between the DataSources tags.

| improve this answer | |
1

I had the same issue and found that turning the Publishing feature on enabled me to insert Data Views in SharePoint Designer.

| improve this answer | |
  • This was the same for me. Turning on the Site Feature "SharePoint Server Publishing" enabled the "Data Source" menu in Designer. – OneOfThePetes Aug 21 '18 at 7:41
1

after making any modification you must press ctrl+S to save the changes then click on another place in the page and all controls will be activated in the ribbon.

| improve this answer | |
  • 1
    Can you please elaborate your answer with some details on why before ctrl+s menus are greyed out. – Asad Refai Aug 4 '15 at 7:17
  • Actually I don't know the reason, but that what happened with me. Is it worked for you? – Mahmoud Aug 5 '15 at 23:01
  • I know I'm coming into this one late. However, I had been experiencing the same issue as detailed above by Anish V. I was unable to Insert a Web Part in SharePoint designer into a Page Layout, because the Web Part button was greyed out. I found that if I saved the Page Layout and then put my cursor in the <ZoneTemplate> tag, the Insert > Web Part button became enabled. – Panter Apr 26 '18 at 17:03
0

There is an oddity in SP designer where if you make any changes some options become disabled. The best thing to do is save it and try again.

| improve this answer | |
0

I also found the Oslo master page will not let you add Data Sources or Data Views. But I had another weird quirk. After parse html and save, I had to add a web part zone before it would enable the button for Data Source.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.